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Nobody’s perfect, including Photoshop and the brilliant folks who created it. 
Programmers can’t anticipate how every single person who uses a program 
will push, prod, and poke it—and on what kinds of computers and under what 

circumstances. So don’t be alarmed if at some point Photoshop acts strangely or 
you just can’t figure out how to make something work. If that happens, there are 
resources aplenty—both within Photoshop and elsewhere—that can help.

The Online Help Desk
Nestled snugly in Photoshop’s aptly named Help menu is Adobe’s online help sys-
tem, which gives you access to answers to common questions and links to tons of 
tutorials. You can take it for a test drive by choosing Help→Photoshop Online Help. 
When you do, Photoshop opens your web browser and points it to the Photoshop 
Help page containing a slew of topics; just click one for more info. At the top left of 
the page is a handy search field where you can enter a choice word or two about 
the tool, technique, or command you’re trying to find (the fewer words, the better). 
Since this page pulls its answers from Adobe’s online database, you need an active 
Internet connection to use it. 

  Troubleshooting 
and Getting Help
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FIGURE B-1
Adobe has posted 
hundreds of pages of in-
formation and tips on its 
online help page (which is 
actually a subpage in the 
Learn & Support section 
of the Photoshop portion 
of their main site, Adobe.
com). Since it’s all Web-
based, Adobe can keep it 
updated, and users can 
add their comments. 

To download Adobe’s help 
content in PDF format 
so you can view it even 
when you don’t have an 
Internet connection, click 
the “Photoshop CC (2014 
release)” link in the Help 
PDFs section (circled).

When Good Tools Go Bad
Sometimes Photoshop’s tools have minds of their own and insist on misbehaving no 
matter how firmly you press the keys or how loudly you curse. Before you announce 
your copy of Photoshop possessed by the Dark Lord of Mordor, make sure you:

• Check the Options bar’s settings. If a brush tool isn’t working, you may have 
changed its opacity or blend mode and forgotten to change it back. Remember, 
settings in the Options bar—as well as in the program’s panels and dialog boxes—
are sticky, meaning they don’t change unless you change them. Nine times out 
of ten, if a tool is behaving or doing something unexpected, it’s because you’ve 
neglected to change a setting back to what you’re used to.

• Make sure you’re on the correct layer. If you’re not, nothing will seem to work. 
Photoshop’s tools won’t appear to have any effect because the changes are 
happening on a different layer than you expect, most likely on a layer you can’t 
see. Take a look at the Layers panel and, if the correct layer isn’t active, click to 
activate the layer you want to affect and then have another go at it.
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• Check for stray selections. If you’ve got an active selection (marching ants) 
somewhere in your document, all kinds of tools and commands can act up. For 
example, a tiny selection can make filters run in the selected area only, keep 
you from activating the Type tool, and so on. Even if you can’t see a selection, 
try pressing c-D (Ctrl+D on a PC) or choosing Select→Deselect just in case, 
and then try using the tool or command again.

• Look for an active Crop or Transform bounding box. Photoshop has a one-
track mind, and if it sees an active Crop or Transform box, it won’t let you do 
anything else until you’ve accepted the crop or transformation by pressing 
Return (Enter on a PC) or bailed out of it by pressing Esc.

• Check your Caps Lock key. If you’re working with a tool that uses a brush cursor 
(say, the Spot Healing or Healing Brush) and the cursor suddenly looks like a 
microscopic crosshair, check to see if you’ve accidentally turned on Caps Lock 
on your keyboard. Once you turn it off, your cursor should be right as rain again.

Believe it or not, these five tips will probably fix the majority of your problems. If 
the trouble persists, see if you can find the solution listed in the next few pages.

Common Problems
Here are some of the most common issues you may run into—and how to fix them.

Mysterious Resizing when Dragging Layers
When you copy and paste an image into an existing Photoshop document or drag 
layers between documents, you might think that items have changed size along the 
way. They didn’t, but it may look like they changed size because either the documents’ 
zoom levels are different or, more likely, their resolutions don’t match. 

As you may remember from page 254, resolution controls pixel size, so if you drag 
a layer from a 72-ppi document into a 300-ppi one, the pixels go from really big to 
really small. The fix is to reduce the resolution of the higher-resolution document 
(which also reduces its print quality) or find a larger image to use instead.

Can’t Save in Certain Formats
Here’s an oldie but goodie: Let’s say you’re poised and ready to save your image 
but the Save As dialog box doesn’t list the file format you want. If that happens, 
there’s a good chance your image is in a funky color mode. For example, Indexed 
color mode (which is used for GIFs) doesn’t let you save in as many file formats as 
RGB mode. To fix this problem, take a trip up to the Image→Mode submenu and 
switch your document to RGB mode, and then try saving it.

Disabled Filters
Have you ever opened the Filter menu only to find that the name of the filter you 
want to run is grayed out and unavailable? If so, you can bet the farm your image 
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is in CMYK mode or 16-bit RGB. Some filters won’t run on anything other than 8-bit 
RGB images, including whole filter categories like Artistic, Brush Strokes, Distort, 
Pixelate, and so on (the Filter Gallery menu item is dimmed on 16-bit images, too). 
To use the unavailable filters, choose Image→Mode→8 Bits/Channel. Then head 
back up to the Filter menu and run the filter you want.

 TIP  If your image is in 8-bit RGB mode but you still can’t use some of Photoshop’s filters, check to see if 
you’re editing a smart object. As you learned on page 670, most but not all filters run as smart filters.

Missing Filters, Plug-Ins, and Adjustments
Photoshop CC is 64-bit compatible on both Macs and PCs, but that doesn’t mean 
every filter, plug-in, and adjustment works in 64-bit mode. If a beloved item is 
missing from the Filter or Image→Adjustments menu, you may need to contact the 
manufacturer for an updated version that’s 64-bit compatible.

Uneditable Images
As you learned earlier in this appendix, you can’t use all of Photoshop’s editing 
features in every color mode the program contains. If you’re suddenly locked out 
of using any of the buttons or menus in the Layers panel (such as masks, adjust-
ment layers, or the Opacity setting), your image is likely in Indexed Color mode (see 
Figure B-2). Simply choose Image→Mode→RGB Color, and you’ll be able to use all 
the Layers panel’s controls again.

FIGURE B-2
Indexed Color mode is great for limiting the number of colors in an 
image that you want to post on the Web, but it also limits other stuff 
like your ability to edit the darn thing using layers. If the Layers panel 
includes a locked layer named Index (as shown here), you’ve found the 
culprit. Switch to RGB mode to regain control.

Resetting Tools
If a tool is behaving erratically, you can give it an attitude adjustment by resetting 
it to its factory-fresh settings. Simply grab the problematic tool and then click the 
tool’s preset menu at the far left of the Options bar. In the resulting drop-down 
menu, click the tiny gear icon at the menu’s top right and choose Reset Tool. If you 
want to reset all your tools, choose Reset All Tools instead.
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Deleting Photoshop’s Preferences
If Photoshop won’t launch, crashes a lot, or is acting funky, you can try zapping its 
preferences (Chapter 1 covers preferences in detail). Damaged preference files can 
cause all those problems and more, and in many cases starting fresh fixes the issue. 
Here’s how to send the program’s preferences packin’:

1. Quit Photoshop if it’s running.

Choose Photoshop→Quit Photoshop (File→Exit on a PC) or press c-Q (Ctrl+Q).

2. Relaunch Photoshop while pressing c -Opt-Shift (on a PC, press 
Ctrl+Alt+Shift while choosing Photoshop from the Start menu).

Press and hold this three-key combo while you launch the program, and don’t 
release the keys until you see the dialog box described in the next step.

3. In the resulting dialog box (Figure B-3), click Yes.

The dialog box asks whether you want to delete your settings file, which is where 
the program stores your preferences; click Yes. (If you somehow happened 
upon this dialog box by mistake or you’ve changed your mind, just click No to 
continue launching the program without deleting any preferences.)

FIGURE B-3
You don’t have to go hunting for Photoshop’s preferences 
files to delete ’em; the program can take care of the dirty 
work for you—if you know the right keyboard shortcut!

The only problem with this fix is that you’ll have to reapply any custom settings you 
had, like extra scratch-disk settings (page 26), guide colors (page 67), and so on. 
But hey, at least Photoshop is running again!

 NOTE  If you use a Mac, trashing Photoshop’s preferences lets you summon the “How do you want the c-H 
keyboard shortcut to behave?” dialog box (see the box on page 8). Besides manually changing your keyboard 
shortcuts as explained in the box on page 31, deleting your preferences is the only way to change this keyboard 
shortcut’s behavior.

Backing Up Presets, Plug-ins, and Actions
Sometimes all the tricks listed above just don’t work, and you have to resort to drastic 
measures: Uninstalling and reinstalling Photoshop. Huge bummer! In that case, be 
sure to back up any custom presets you’ve made like actions, brushes, swatches, 
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and so on, and make copies of any third-party plug-ins you’ve installed (unless you 
have the installers for the add-ons lying around on your hard drive).

 TIP  You can also sync your settings and presets to the Adobe Creative Cloud for safekeeping and easy 
reinstallation, as explained on page 23. (This trick doesn’t work for plug-ins.)

Where do the custom goodies live on your hard drive? On a Mac, they’re stashed 
in the Users/[your home directory]/Library/Application Support/Adobe/Adobe 
Photoshop CC 2014/Presets folder. On a PC running Windows they live in C:\Users\
[your user name]\AppData\Roaming\Adobe\Adobe Photoshop CC 2014\Presets. 
It’s a good idea to copy the Presets folder to someplace safe, like an external hard 
drive even if you have synced ’em with the Adobe Creative Cloud; see page 23. 
Any plug-ins you’ve installed live in the Plug-ins folder, which is inside the Adobe 
Photoshop CC program folder on a Mac (they’re in the main Adobe folder on a PC), 
so be sure and copy those, too. (You can’t sync plug-ins with the Creative Cloud.)

Once your files are safely copied somewhere else, head over to online Appendix A 
for the scoop on uninstalling the program.

 NOTE  For some reason, Apple made the user Library folder hidden with the release of OS X 10.7. To get to it 
from the Finder, click the Go menu to open it, and then press and hold the Option key and click the Library menu 
item that appears. Le sigh.

Beyond This Book
Thanks to a vast number of gifted trainers, great magazines, and helpful websites 
devoted to the program, Photoshop users will never be left out in the cold. It is, after 
all, the most popular piece of software to date. Adobe’s website is a great place 
to start rooting around for additional info. You’ll find a design center with written 
and video tutorials (www.adobe.com/inspire), along with some of the most active 
forums you’ll ever run across. Folks post and reply to questions so often it’ll leave 
you wondering whether they’ve got jobs!

But some of the best content isn’t available from Adobe—it’s posted online by a wide 
variety of sources. Aside from your fearless author’s own website (which appears first 
in the list below), there are a bazillion other sites bursting with useful, well-written 
tutorials, videos, shortcuts, and downloads. All the resources listed below are free 
unless otherwise noted, so visit them all and bookmark the ones you like best. And 
if you ever get a chance to take one of their classes, you’ll be glad you did!

• PhotoLesa.com. Your author is on a mission to teach the world to create—and 
use!—better graphics. To that end, she created this free tutorial site. You’ll find 
a new tutorial posted every few weeks, along with videos, news, and info on 
upcoming workshops (www.photolesa.com).

http://www.photolesa.com
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• creativeLIVE.com broadcasts oodles of Photoshop workshops taught by some 
of the best instructors in the world. You can watch ’em for free online while 
they’re happening, or pay a small fee to access the videos later. Your author 
frequently teaches classes for these folks (www.lesa.in/lesacl). 

• Planet Photoshop is a news and tutorial hub for the Photoshop community. 
It’s managed by the people who run KelbyOne (described in the next bullet 
point), and your author also contributes free video tutorials to this site (www.
planetphotoshop.com).

• KelbyOne (previously NAPP, the National Association of Photoshop Profession-
als) is the world’s largest professional Photoshop organization. Its website is 
loaded with articles, tutorials, and tips, plus it’s the organization that publishes 
Photoshop User magazine (be sure to look for your author’s monthly “Begin-
ner’s Workshop” column!). A $99 yearly membership fee gets you the magazine, 
access to a help desk, discounts on PhotoshopWorld.com conferences, and a 
slew of other benefits (www.photoshopuser.com).

• CreativePro.com is packed with useful information for Photoshop fans, graphic 
designers, and creative professionals. It covers industry news and offers tips 
and tricks for all the Adobe Creative Suite programs (www.creativepro.com).
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