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Appendix

B

Nobody's perfect, including Photoshop and the brilliant folks who created it. 
Programmers can't anticipate how every single person who uses a program 
will push, prod, and poke it—and on what kinds of computers and under what 

circumstances. So don't be alarmed if at some point Photoshop acts strangely or 
you just can't figure out how to make something work. If that happens, there are 
resources aplenty—both within Photoshop and elsewhere—that can help.

The Online Help Desk
Nestled snugly in Photoshop's Help menu is the program's own Help system, which 
gives you access to answers to common questions and links to tons of tutorials. You 
can take it for a test drive by choosing Help→Photoshop Online Help. When you do, 
Photoshop opens your web browser to the Photoshop Help page containing a slew 
of topics; just click one for more info. At the top left of the page is a handy search 
field where you can enter a choice word or two (the fewer the words, the better). 
Since this page pulls its answers from Adobe's online database, you need an active 
Internet connection to use it. 

B

 Troubleshooting 
and Getting Help
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Figure B-1

Adobe has hundreds of 
pages of information and 
tips online. Since it’s all 
Web-based, Adobe can 
keep it updated, and 
users can add their own 
comments. 

To view Adobe-sanc-
tioned info on registering 
the program, installation 
problems, and other is-
sues, click the Photoshop 
Help hyperlink (circled) to 
view the main Photoshop 
Help page. When you 
do, Photoshop launches 
another program called 
the Adobe Help Manager. 
You can use this program 
to download help content 
in PDF format so you can 
view it even when you 
don’t have an Internet 
connection.

 Note  As of this writing, the official help content for CS6 isn't quite finished so you can't download any PDFs 
just yet. Be sure to check back often by choosing Help→Photoshop Online Help.

When Good Tools Go Bad
Sometimes tools have minds of their own and insist on misbehaving no matter how 
firmly you press the keys or how loudly you curse. Before you announce your copy 
of Photoshop possessed by the Dark Lord of Mordor, make sure you:
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•	 Check the options bar's settings. If a brush isn't working, you may have 
changed its opacity or blend mode and forgotten to change it back. Remember, 
settings in the Options bar (page 13)—as well as panels and dialog boxes, for 
that matter—are sticky, meaning they don't change unless you change them. 
Nine times out of ten, if a tool is behaving or doing something unexpected, it's 
because you've neglected to change a setting back to what you're used to.

•	 Make sure you're on the right layer. If you're not, nothing will seem to work. 
Photoshop's tools won't seem to have any effect because the changes are hap-
pening on a different layer than you expect, most likely on a layer you can't see. 
Take a look at the Layers panel and, if the right layer isn't active, click to activate 
the layer you want to affect and then have another go at it.

•	 Check for stray selections. If you've got marching ants somewhere on your 
image, it can make all kinds of tools act up. For example, a tiny selection can 
make filters run in the selected area only, keep you from activating the Type 
tool, and so on. Even if you can't see a selection, try pressing c-D (Ctrl+D on 
a PC) or choosing Select→Deselect just in case. Then try using the tool again.

•	 Look for an active Crop or transform bounding box. Photoshop has a one 
track mind, and if it sees an active Crop or Transform box it won't let you do 
anything else until you've accepted the crop or transformation by pressing 
Return (Enter on a PC) or bailed out of it by pressing Esc.

•	 Check your Caps Lock key. If your brush cursor or other tool start going wonky, 
check to see if you've accidentally turned on Caps Lock on your keyboard. Once 
you turn it off, your tools should be right as rain again.

Believe it or not, these four tips will probably fix the majority of your problems. If 
the trouble persists, see if you can find the solution listed in the next several pages.

Mysterious Resizing when Dragging Layers
When you copy and paste an image into an existing Photoshop document (page 
92) or drag layers between documents (page 103), you might think that items have 
changed size along the way. They didn't, though—it only looks like they changed 
size because either the documents' zoom levels are different or, more likely, their 
resolutions don't match. As you may remember from Chapter 6, resolution controls 
the size of pixels, so if you drag a layer from a 72-ppi document into a 300-ppi one, 
the pixels go from really big to really small. The fix is to reduce the resolution of the 
higher-resolution document (which reduces its print quality), or find a larger image 
to use instead.

Can't Save in Certain Formats
Here's an oldie but goodie: Let's say you're poised and ready to save your image 
but the Save As dialog box (page 48) doesn't list the file format you want. If that 
happens, there's a good chance your image is in a funky color mode (page 45). For 
example, Indexed color mode (which is used for GIFs) doesn't let you save in as 
many file formats as RGB mode. To fix this problem, take a trip up to Image→Mode 
and switch your document to RGB mode, and then try saving it.
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Disabled Filters
Have you ever opened the Filter menu only to find that the name of the filter you 
want to run is grayed out and unavailable? If so, you can bet the farm your image is 
in CMYK mode or 16-bit RGB. Several filters won't run on anything other than 8-bit 
RGB images, including whole filter categories like Artistic, Brush Strokes, Sketch, 
Texture, and so on. To use the unavailable filters, choose Image→Mode→8 Bits/
Channel. Then head back up to the Filter menu and run your filter.

 tip  If your image is in 8-bit RGB mode but you still can't use some of the filters, check to see if you're editing 
a Smart Object (page 126). As you learned on page 634, not all filters run as Smart Filters.

Missing Filters, plug-ins, and Adjustments
Photoshop CS6 is 64-bit compatible on both Macs and PCs, but that doesn't mean 
every filter, plug-in, and adjustment works in 64-bit mode. If a beloved item is missing 
from the Filter or Image→Adjustments menu and you're on a PC, don't panic. Just 
quit the program and then relaunch it in 32-bit mode to make the item reappear. 
On a PC, the installer puts two different versions of the program on your computer 
(there's no 32-bit version of Photoshop CS6 for the Mac); just locate the 32-bit ver-
sion and you're good to go.

Uneditable images
As you learned earlier in this appendix, you can't use all of Photoshop's editing fea-
tures in every color mode. If you're suddenly locked out of using any of the buttons or 
menus in the Layers panel (like masks, Adjustment layers, or opacity), your image is 
probably in Indexed Color mode (see Figure B-2). Simply choose Image→Mode→RGB 
Color and you'll be able to use all the Layers panel's controls.

Figure B-2

Indexed Color mode is great for limiting the number of colors in an image you want to post 
on the Web, but it also limits other stuff like your ability to edit the darn thing using layers. 
If the Layers panel includes a locked layer named Index (as shown here), you’ve found the 
culprit. Switch to RGB mode to regain control.
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Resetting tools
If a tool is behaving erratically, you can give it an attitude adjustment by resetting it 
to its factory-fresh settings. Grab the problem tool and then click the tool's preset 
menu at the far left of the Options bar. In the resulting pop-up menu, click the tiny 
gear icon at the menu's top right and choose Reset Tool. If you want to reset all your 
tools, choose Reset All Tools instead.

trashing photoshop's preferences
If Photoshop won't launch, crashes a lot, or is acting funky, you can try zapping 
its preferences (Chapter 1 covers preferences in detail). Damaged preference files 
can cause all those problems and more, and in many cases starting fresh fixes the 
problem. Here's how to delete the program's preferences:

1. Quit photoshop if it's running.

Choose Photoshop→Quit Photoshop (File→Exit on a PC) or press c-Q (Ctrl+Q).

2. Relaunch photoshop while pressing c-opt-Shift (on a pC, press 
Ctrl+Alt+Shift while choosing photoshop from the Start menu).

Press and hold this three-key combo while you launch the program, and don't 
release the keys until you see the dialog box described in the next step!

3. in the resulting dialog box (Figure B-3), click Yes.

Photoshop asks whether you want to delete your settings file, which is where 
the program stores your preferences. (If you somehow happened upon this 
dialog box by mistake or you've changed your mind, just click No to continue 
launching the program without deleting any preferences.)

Figure B-3

You don’t have to go hunting for Photoshop’s preferences 
files to delete them; the program takes care of the dirty 
work for you—if you know the right keyboard shortcut!

The only problem with this fix is that you'll have to reapply any custom settings you 
had, like extra scratch disk settings (page 33), guide colors (page 36), and so on. 
But hey, at least Photoshop is running again!
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 Note  If you're a Mac user, trashing Photoshop's preferences is the only way you can get the "How do you 
want the c-H keyboard shortcut to behave?" dialog box to appear (see the box on page 13). Besides manually 
changing your keyboard shortcuts as explained in the box on page 37, deleting your prefs is the only way to 
change this keyboard shortcut's behavior.

Backing Up presets, plug-ins, and Actions
Sometimes all the tricks listed above just don't work, and you have to resort to drastic 
measures: Uninstalling and reinstalling Photoshop. Huge bummer! In that case, be 
sure to back up any custom presets you've made like actions, brushes, swatches, 
and so on, and make copies of any third-party plug-ins you've installed (unless you 
have the installers or DVDs for the add-ons lying around).

All of your custom goodies are stashed in the Users/[your home directory]/Library/ 
Application Support/Adobe/Adobe Photoshop CS6/Presets folder. On a PC running 
Windows 7 they live in C:\Users\[your user name]\AppData\Roaming\Adobe\Adobe 
Photoshop CS6\Presets. Copy the Presets folder to someplace safe, like an external 
FireWire or USB hard drive. Any plug-ins you added are in the Plug-ins folder, which 
is inside the Adobe Photoshop CS6 program folder on a Mac (they're in the main 
Adobe folder on a PC), so copy those, too.

Once your files are safely copied somewhere else, head over to online Appendix A 
for the scoop on uninstalling the program.

Beyond this Book
Thanks to a vast number of gifted trainers, great magazines, and helpful websites 
devoted to the program, Photoshop users will never be left out in the cold. It is, after 
all, the most popular piece of software to date. Adobe's website is a great place to 
start rooting around for additional info. You'll find a design center with written and 
video tutorials (www.adobe.com/designcenter), along with some of the most active 
forums you'll ever run across. Folks post and reply to questions so often it'll leave 
you wondering whether they've got real jobs!

But some of the best content isn't available from Adobe—it's posted online by a 
wide variety of sources. Aside from your fearless author's own website (which ap-
pears first in the list below), there are a bazillion other sites bursting with useful, 
well-written tutorials, shortcuts, and downloads. All the resources listed below are 
free unless otherwise noted, so visit them all and bookmark the ones you like best. 
Also included are some of the most amazing Photoshop instructors and authors out 
there. If you ever get a chance to take one of their classes, you'll be glad you did!
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•	 photoLesa.com. Your author is on a mission to teach the world to create—and 
use!—better graphics. To that end, she created this free tutorial site. You'll find 
a new tutorial posted every few weeks, along with info on her latest online 
workshops, and more (www.photolesa.com).

•	 planet photoshop is a news and tutorial hub for the Photoshop community. 
It's managed by the folks who run NAPP (described in the next bullet point), 
and your author contributes free video tutorials to this site weekly (www.lesa.
in/lesaplanet.com).

•	 the National Association of photoshop professionals (NAPP) is the world's 
largest professional Photoshop organization. Its website is loaded with articles, 
tutorials, and tips, plus it's the organization that publishes Photoshop User 
magazine (be sure to look for your author's "Beginner's Workshop" column in 
the magazine!). A $99 yearly membership fee gets you the magazine, access 
to a help desk, discounts on PhotoshopWorld.com conferences, and a slew of 
other benefits (www.photoshopuser.com).

•	 Creativepro.com is packed with useful information for Photoshop fans, graphic 
designers, and creative professionals. It covers industry news and offers tips 
and tricks for all the Adobe Creative Suite programs (www.creativepro.com).

•	 Design tools Monthly collects all the news that's important to folks in the 
graphic design world—including digital photographers—and serves it up every 
month in easy-to-digest bits along with tips, fonts, and software updates. 
You can think of it as the executive summary of graphic-design news (www.
designtoolsmonthly.com).

http://www.photolesa.com

