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iLife Crash Course

This appendix, revised by Abe Handler, is designed to accompany Switching to the Mac: The 
Missing Manual, Lion Edition.

Does coverage of iLife (iMovie, iDVD, and iPhoto) belong in a Mac OS X 
book?

It’s a tricky question. No, iLife doesn’t come with Mac OS X. But iLife does 
come on every Mac. So if you have Mac OS X, you also have iLife.

On the other hand, iLife keeps changing (and growing). If you put chapters about 
iLife into a Mac OS X book, the iLife chapters can go out of date before the Mac OS 
X book does. Not to mention the enormous number of pages you’d add to an already 
huge book. Here, before you, is one solution: a free basic iLife crash-course appen-
dix, containing everything you need to get going.

Note: The iDVD, iMovie, and iPhoto sections of this appendix are adapted from iMovie ’11 & iDVD: The 
Missing Manual and iPhoto ’11: The Missing Manual—which are great books, by the way.

iMovie ’11
If you have a digital camcorder and a few hours of free time—all right, a few week-
ends of it—iMovie helps you make astonishingly high-quality, fully edited movies. 
Digital video is great: You can transfer the footage back and forth between your Mac 
and your camcorder a hundred times and never see any deterioration in quality. 
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iMovie can even edit high-definition footage. This section will teach you everything 
you need to get started.

Importing from a Tape Camcorder
If you have a MiniDV tape camcorder, high-def or not, transferring your record-
ings to a Mac for editing is straightforward. All you have to do is connect your two 
machines—the camcorder and the Mac—with a FireWire cable.

Note: Unfortunately, not all Mac models have FireWire jacks anymore, or they use a newer jack called 
FireWire 800. If your Mac has a FireWire 800 jack, you can find a cable that works with your camera (do 
a Google search or check the manufacturer’s accessories web page). The MacBook Air and the regular 
aluminum MacBook, though, lack any FireWire jack. So if you have MiniDV tapes full of recorded video, 
you’re out of luck: There’s no adapter box or converter that connects your camcorder’s FireWire jack to a 
Mac that doesn’t have this jack. Your best bet is to borrow a Mac that has a FireWire jack, dump all of your 
tapes onto it, and then sell your old camcorder.

The big end of the cable goes into the FireWire jack on the front, side, or back of 
your Mac; it’s marked by a radioactive-looking f symbol. Plug the other end into 
the FireWire connector on your camcorder, which, depending on the brand, may 
be labeled “FireWire,” “i.Link,” or “IEEE 1394.” (It’s almost always hidden behind a 
plastic or rubber door or flap on the camcorder.) Then, proceed like this:

1.	 Turn	on	the	camcorder	and	switch	it	into	Play	mode.
The camcorder’s playback mode may be labeled Play, VCR, VTR, or just 2. At 
this point, iMovie’s big blue Import window opens automatically.

Tip: You’ll probably want to open the camcorder’s LCD screen, which also turns on its speaker. Otherwise, 
you’ll have no way to hear the audio as you play back the tape.

2.	 Tell	iMovie	what	you	want	to	import.
If you want to import the whole tape, make sure the Automatic/Manual switch 
(in the lower left of the Import From window) is set to Automatic, and then click 
Import. This is a convenient option, since you can walk away and do other things 
while iMovie works. Once iMovie finishes importing your footage, it displays a 
“Save to” dialog box (below); skip to step 3.
If you want to import only some of what’s on the tape, set the Automatic/Manual 
switch to Manual. When you do, the window sprouts a set of playback controls. 
Use them to control your camcorder as it scans the tape to find the sections you 
want to include in your movie.
When you find a shot that’s worth bringing onto the Mac, click the Import button 
at the lower-right corner of the window. The “Save to” dialog box appears; read on.
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3.	 Indicate	where	you	want	to	save	the	imported	video	clips.
Most people, most of the time, save incoming video onto their main Mac hard 
drive. But true iMovie addicts wind up buying additional hard drives to hold 
their movies. That’s why the “Save to” pop-up menu appears here—so that you 
can choose a different hard drive to hold your video.

4.	 Specify	an	Event.
The pair of choices shown above let you answer these questions: Were the scenes 
you’re about to import filmed at a new Event? Or should they more properly be 
filed along with scenes you’ve already imported as part of an existing Event?
Selecting the right option, of course, requires that you know what Apple means 
by an Event. Check out the box on page 5 of this appendix for the lowdown.

Tip: iMovie can analyze your footage to make it look less wobbly (page 27 of this appendix) or to identify 
the shots with people in them (page 49 of this appendix). If you’re not in a rush to import your footage, 
this might be a good time to set iMovie to work on these time-consuming tasks. Just turn on “Analyze for 
stabilization and/or people” (shown above).

5.	 If	you	have	a	high-definition	camcorder,	choose	either	“Large	–	960x540”	or	
“Full	–	1920x1080.”
This final option appears only when you’re importing video from a high- 
definition camcorder, one that captures 720p, 1080i, or 1080p footage.
iMovie is offering you the chance to import a smaller-scale version of that 
gigantic video canvas so you can save hard drive space. The odds are good 
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that you won’t see much visual difference on most TVs if you choose Large, so 
choose Full only for the most precious, save-for-the-future kinds of footage.

6.	 Click	Import.
If you chose the Automatic option, iMovie now rewinds the tape to the begin-
ning, then tells the camcorder to begin playback. As it plays, iMovie captures 
the video and stores it on your Mac. You can interrupt the process by clicking 
Stop, if necessary; at this point, iMovie displays a little congratulations message, 
revealing how many minutes’ worth of video you imported. You can click OK 
and then import some more, if you like, by starting from step 2 above.
Or you can Click Import and then walk away while iMovie works. You can even 
surf the Web, crunch some numbers, organize your pictures in iPhoto, or what-
ever you like. Since iMovie is a Mac OS X program, your Mac doesn’t have to 
devote every atom of its energy to capturing video. It gives priority to the video, 
so your other programs may act a little drugged, but you can get meaningful 
work or reading done while you’re dumping your footage into iMovie in the 
background.
If you let the Automatic importing proceed without interruption, iMovie auto-
rewinds the tape when it reaches the end.
If you chose the Manual setting, you can use iMovie’s playback controls to operate 
the tape, shuttling through the video to find the parts you want; use the Import 
button (and its alter ego, the Stop button) to capture only the good parts. 
Unfortunately, the process isn’t the speedy joyride it was in the pre-’08 versions 
of iMovie, where you could just tap the space bar (or click Import) every time 
you wanted to start or stop importing during playback.
In iMovie ’11, each time you click Stop, iMovie locks you out for a minute or two 
while it displays the “Generating Thumbnails” message. That’s iMovie’s way of 
saying, “I’m processing this video and making some live, ‘skimmable’ filmstrips” 
(which are described below).
Once that message disappears, you can use the playback controls to find the 
next bit of video that’s worth importing—but you’ll have to fill out the box 
shown above all over again, every time.
These frequent “Generating Thumbnails” and “Save to” interruptions are, for 
many people, a pretty strong argument for avoiding the Manual settings. The 
Automatic setting winds up saving you a lot of time—and doesn’t cost you any 
extra disk space. 

7.	 When	you	and	iMovie	are	both	finished,	click	Done.
The Import window goes away. You return to the iMovie screen, where you can 
click the name of the Event you specified in step 4 to see the newly imported 
clips.
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Up To Speed

The Definition of an Event
In iMovie terms, an Event is an organizational tool, like a 
label or a desktop folder.

Sometimes, what constitutes an Event is obvious. A wed-
ding, a graduation, a birthday party, and a ski trip, for ex-
ample. You’d want all the clips from somebody’s wedding 
filed under a single heading, even if you film them over the 
course of a whole weekend.

Sometimes, though, “Event” is a little nebulous. What if you 
film little scenes of your new baby every other day for a 
couple of months? Would they all be one Event called “Au-
gust”? Or would you have a lot of little Events like “Over-
turned spaghetti bowl” and “First steps”?

Or what if you take a 10-day cruise featuring a stop every 
other day in a different port of call? Would the Event be 
“Mediterranean Cruise”? Or would you create individual 

Events for “Naples,” “Monaco,” and “Tunisia”?

The answer is, of course, “That’s up to you.” And that’s why 
the options in step 4 (page 3) appear at this point. If you 
want to create a new Event, type a name for it into the “Cre-
ate new Event” box. But if you’re importing footage into an 
Event category you already created, click “Add to existing 
Event,” and then choose that Event from the pop-up menu.

Note: If you opt to create a new Event, iMovie also offers 
you a checkbox called “Split days into new Events.” If you 
turn this option on, each day’s worth of shooting becomes 
an Event all its own, even if you shot all the footage on the 
same vacation or wedding weekend. iMovie automatically 
adds day numbers to Event names, like “Wedding–Day 1” 
and “Wedding–Day 2.”

Automatic Scene Detection
You’ll notice a handy feature when iMovie finishes importing footage: The program 
automatically creates an individual filmstrip (clip) for each scene you shot. So an 
hour’s worth of tape doesn’t wind up as a single, mega-chunk of video—instead, you 
wind up with 30 or 40 individual clips, just the way you shot them. 

You get these separate chunks of video because, behind the scenes, iMovie studies 
the date and time stamp that your camcorder recorded with every frame of video. 
When iMovie detects a break in time, it assumes that you stopped recording, if only 
for a moment, and considers the next piece of footage a new shot. It turns each new 
shot into a new clip. (In general, this feature doesn’t work if you haven’t set your 
camcorder’s clock, or if you’re playing from a nondigital tape.)

Importing from Tapeless Camcorders
The beauty of tapeless camcorders is that, because they store video as computer files 
on a hard drive, DVD, or memory card, you don’t have to wait for clips to play back 
in real time so iMovie can save them to your Mac. Instead, the importing process 
takes only as much time as iMovie needs to copy those files onto your Mac’s hard 
drive. (At least in theory; read on.)
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Once you’re ready to transfer some video from your camcorder, here’s how you 
should proceed.

1.	 Connect	the	camcorder’s	USB	cable	to	the	Mac.
Most tapeless camcorders connect to the Mac using a USB cable, which comes 
with your camcorder. If you have a Flip camcorder, plug in it’s pop-out USB 
connector instead.

2.	 Turn	on	the	camcorder	and	switch	it	into	PC	mode.
The wording might vary, but every tapeless camcorder has a mode for making 
PC or Mac connections.
If everything goes well, a message appears at the top of the screen that says, 
“Generating Poster Images.” Then, after a minute, you see the Importing screen 
depicted here. (If iMovie doesn’t open, or if the Importing screen doesn’t appear, 
then choose File→Import From Camera.)
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You’re about to experience one huge payoff of using a tapeless camcorder: 
instant access to individual scenes on the camcorder. That means, first of all, 
that you don’t have to rewind or fast-forward to find a certain shot. Further-
more, as you can see above, iMovie lets you import only the shots you want, 
leaving the duds behind. That feature alone can represent a huge time savings 
over the old “import the whole tape” method.

3.	 Review	your	shots	before	you	import	them.
To play a shot, click its thumbnail and then click the 2 button. Click the ‚ or fi 
buttons to skip to the previous or next shot on the camcorder (or just click the 
thumbnails on the screen in front of you).

4.	 Specify	which	shots	you	want	to	import.
If you want to import everything on the camcorder, click Import All and then 
skip to step 5.
If you want to import only some of the shots, move the Automatic/Manual 
switch in the lower-left corner of the Import window to Manual. Now you’ll see 
little checkboxes under the shot thumbnails. All of them start out with check-
boxes turned on, meaning that iMovie intends to import all of them. Turn off 
the checkboxes below the ones you don’t want, and then click Import Checked.
At this point, the top of the window displays the “Save to” dialog box shown 
back on page 3.

5.	 Tell	iMovie	where	you	want	to	save	your	imported	clips.
Most people save the incoming clips onto the main Mac hard drive. But if you’ve 
bought additional hard drives to hold your movies, you can use the “Save to” 
pop-up menu to choose a different drive.

6.	 Specify	an	Event.
The pair of choices shown above let you answer these questions: Are the scenes 
you’re importing part of a new Event, or should iMovie file them with scenes 
you already imported as part of an existing Event? (See the box on page 5 for 
info about what iMovie considers an “Event.”)

7.	 If	you	have	a	high-def	camcorder,	choose	either	“Large	–	960x540”	or	“Full	–	
1920x1080”.
You may not see this final option. It appears only when you’re importing vid-
eo from a high-definition camcorder, one that captures 720p, 1080i, or 1080p 
video. Choosing Full stores a really big version of your video that will eat up 
precious space on your hard drive—and you won’t even notice the improved 
video quality on most TVs. In general, only pick Full for really important, want 
to-have-forever sorts of video.

8.	 Analyze	for	stabilization	and/or	people,	if	you’ve	got	the	time.	
iMovie’s built-in footage stabilizer is one of its most important—and most 
 effective—features. It converts unsteady video into footage that looks as though 



8 ilife crash course

iMovie ’11

the camera was on a tripod. The people-finder feature tags clips containing 
faces, making them easier to find later (see the Tip on page xx of this guide for 
more info). But this “analysis” can take hours. If you’re not in a rush, let ‘er rip. 
Otherwise, you can always do this later (see page 49 of this appendix for more 
on People, or page 27 of this appendix for more on stabilization).

9.	 Click	Import.
iMovie swings into action. It begins slurping in the video from the camcorder’s 
hard drive, DVD, or memory card. As it works, a progress counter ticks off the 
remaining shots left to import.
Considering that a tapeless camcorder is supposed to spare you the agony of 
importing footage from a tape in real time, you may be surprised at how long 
the importing takes. So-called AVCHD footage (high-def footage on camcorders 
that record onto memory cards or hard drives), in particular, takes a long time 
because iMovie has to convert it to an editable format; depending on the speed of 
your computer, you may wind up waiting 2.5 minutes for each minute of video. 
So an hour’s worth of video can take two and a half hours to import. You’ve been 
warned.
But never mind that; once the job is done, a message appears to congratulate 
you. It lets you know how many minutes and seconds of video you’ve imported, 
total, and how many clips.

10.	 Click	OK.
The congratulations message goes away.

11.	 Click	´ to	eject	the	camcorder,	and	then	click	Done.
The Import screen goes away. You arrive at the main iMovie screen, where 
your new video appears in the Events list at the left side of the screen. Page xx 
describes this structure in more detail.

You can now turn off the camcorder to save battery power, if you like.

Importing from an iPhone or iPod Touch
If you have an iPhone (iPhone 3GS or later) or camera-equipped iPod Touch, you’ve 
probably been pulling it out of your pocket to shoot all kinds of great moments. Now 
you’d like to import those clips into iMovie to start editing. 

In true, smooth Apple fashion, everything you read about importing video from 
tapeless cameras applies here. iMovie ’11 automatically recognizes your iPhone or 
Touch, just as it does a regular tapeless camcorder. It also lets you select individual 
clips to import. iMovie even offers the same import options for analyzing and/or 
optimizing your footage.
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The only real difference is that plugging in your iPhone or iPod Touch still opens 
iTunes automatically and starts syncing, even if you only want to import clips into 
iMovie (a minor annoyance that you can turn off in iTunes if you really want to).

Importing from DVD Camcorders
In general, DVD camcorders are a mess. They’re fussy, they take a long time to 
“initialize” and “finalize” a blank DVD, each disc doesn’t hold very much footage, 
the recorded discs may not have a very long lifespan, and the miniature DVDs can 
actually damage your Mac.

If that’s what you’ve got, though, the routine for importing video from a DVD 
 camcorder—at this writing, the most popular format on the market—is exactly the 
same as it is for other tapeless camcorders. The instructions begin on page 5 of this 
appendix.

There are, however, a couple of caveats:

• iMovie ’11 doesn’t import video from DVD camcorders that use the AVCHD 
video format. Unfortunately, that pretty much rules out all high-definition DVD 
camcorders.

• Thanks to the hostility of the engineers who dreamed up the recordable DVD 
camcorder disc, most DVD camcorders offer multiple recording formats, with 
such cheerful names as DVD-Video and DVD-VR. Each has tradeoffs: One 
plays back in more DVD players, another lets you erase scenes before commit-
ting them to plastic, and so on.
The thing is, you have to choose which format you want when you put the blank 
DVD into the camcorder. That’s when the screen offers you the choice of formats. 
The key here is to choose the DVD-Video format, sometimes called Standard. 
If you choose VR or DVD-VR instead, iMovie won’t be able to import your 
recorded video. (When you connect the camcorder, it thinks that you’ve just 
inserted a DVD, rather than thinking that you’ve attached a disk full of video.)

Importing Old iMovie Projects
Most software companies, most of the time, stick with certain time-honored tradi-
tions concerning software upgrades. One of them is compatibility: If you release 
BeeKeeper Pro 7, it goes without saying that it can open files created by BeeKeeper 
Pro 6.

iMovie ’08, ’09 and ’11, though, aren’t updated version of iMovie 6 (also known as 
iMovie HD); they’re versions 1.0, 2.0, and 3.0 of a completely different program, 
written from scratch. Because of that, their ability to import older iMovie projects is 
extremely limited.
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To bring in an older iMovie project, choose File→Import iMovie HD Project. This 
dialog box appears:

Once you’ve decided where to save the imported, converted project and chosen 
Large or Full (go with Large unless it’s a really important video), navigate to the 
iMovie project you want to import and double-click its name or icon.

iMovie ’11 springs into action, importing the video clips (making new copies of 
them) and generating the filmstrip thumbnails that you’ll work with as you edit. 
This process can take a good long time.

When it’s all over, whatever clips you had in the old project’s iMovie timeline appear 
in the Project (storyboard) area, in the correct sequence, correctly trimmed. iMovie 
imports leftover clips, too—the ones left unused in the Clips pane of your old project. 
They show up in the Event that contains your project, just in case you want to add 
them to the project later.

On the other hand, iMovie ’11 brings in only a few basic elements of the original 
iMovie project. To be precise:

• You	get	only	the	clips. iMovie ’11 ignores all effects, titles, and credits.
• You	lose	all	the	audio	work	you	did. iMovie ’11 ignores everything in the old 

iMovie’s two audio tracks, including music, narration, sound effects, and any 
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audio “paste-over” cutaways. The only audio that carries over are the sounds in 
your project’s video clips.

• iMovie	replaces	all	your	scene	transitions. If you used any transition effects in 
your old project, iMovie ’11 replaces them all with generic crossfade dissolves.

If you really, truly want to go to all this trouble, you can now start over again, repairing 
and reconstructing the movie, restoring the elements that got lost during the import 
process. You might find the effort worthwhile if you want to use some of the iMovie ’11 
tools that aren’t available in the old iMovie, like video cropping or rotation or one-click 
exporting to YouTube.

Otherwise, though, consider leaving your old iMovie projects just as they are. If you 
have iMovie 6 on your computer, it might make more sense to leave your old projects 
in their original format.

Dragging Video In from the Finder
iMovie can import movies directly from your hard drive, too—no camcorder 
needed. Position the iMovie window so you can see your movie files in the Finder, 
and then drag the files’ icons directly onto an Event in iMovie’s Event list. (Each 
clip icon is different—iMovie creates the icon stills from actual footage.)

Alternatively, use the File→Import→Movies command to find and select the movies 
you want to import. iMovie asks which Event you want to save the imported flicks to.

Either way, you wind up with your digital movie files in an Event and ready to edit.

Importing with iMovie’s Drop Box Folder
If you’re short on time and you have a stack of videos you want to import, iMovie 
’11’s new Drop Box folder is your friend. iMovie will import any video files in this 
folder the next time you open the program. This way, you can simply drop your 
movie files into the folder and forget about them. Then, the next time you launch 
iMovie, it imports the files. And if you’re a pro with automation programs, like 
 AppleScript or Automator, this folder becomes even handier. 

Look in your iMovie Events folder (page xx) to find the folder called iMovie Drop 
Box. After you add files to this folder, iMovie displays a message like the one shown 
below the next time you open the program. Click Import Now, and iMovie displays 
an Import window much like the one you saw on page 3 of this appendix. (For some 
reason, this window is missing the Stabilization checkbox. You’ll have to analyze this 
footage later, as explained on page 27 of this appendix).
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The Lay of the Land
Before you dive in and start chopping and rearranging your video into a finished 
masterwork, it’s worth sampling this brief section on what, exactly, iMovie is up to.

The Concept of Movie Projects
A project, in iMovie lingo, is an edited movie. The reason you’re learning iMovie in 
the first place is to create these projects.

In early versions of iMovie, a project was an icon on your desktop. This was convenient 
in one way—you could move the whole thing to another computer or back it up easily, 
for example. But in another way, it wasn’t ideal. If you wanted to use a particular piece of 
video in more than one project, you’d have to duplicate it (by pasting it into the second 
project), which ate up a lot more hard drive space.

iMovie ’11 operates on a totally different system. The idea here is that your Events 
list (click  in the lower left of the iMovie window) shows every piece of video on 
your entire Mac—even video on other hard drives. All of that video is available to all 
your projects, all the time.

When you choose a video clip to use in a project, you’re not moving it anywhere. 
You’re just providing a pointer for the project, showing iMovie where to look for each 
piece of video you want it to play. This new system has a number of implications:
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• You can use the same video clips in dozens of different movie projects without 
eating up more disk space.

• You can create multiple versions of the same project—a long one and a short 
one, for example—without worrying about filling up your hard drive.

Note: Yes, each project takes up disk space, but only an infinitesimal amount—about as much as a word-
processing document—since it contains only a text list of pointers to bits of video on your hard drive.

• There’s no longer any easy way to back up or move a single project. Yes, there’s a 
folder that contains your individual project files. (It’s the Home→Movies→ iMovie 
Projects folder.) But if you try to drag one of these project files to another disk, 
you’ll have nothing, because you’ll be leaving behind the raw video that it points to.

When you’re finished editing a project, you’ll probably want to send it somewhere: to 
YouTube, to a DVD, to a QuickTime movie, or whatever (page 55 of this appendix has 
the details). Only then does iMovie meld together the editing information stored in 
the project file with the video information stored in the Events Library to produce a 
single, sharable movie file.

Creating a Project
To create a new project, you have three choices:

• Choose File→New Project.
• Press c-N.
• Click the + button beneath the Projects list.

Whichever route you choose, the New Project sheet appears:
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Here’s where you give the project a name and choose an aspect ratio for it (standard 
squarish TV-size or widescreen). You can also choose the theme and transitions you 
want iMovie to automatically apply; those topics are covered on pages 30 and 28 of 
this appendix, respectively.

All About Events
At the lower-left corner of the iMovie window is the Events Library. It’s supposed to 
be a massive repository of all the video on your entire computer, from all sources:

It’s organized like this:

• Last	Import. Click this heading to view, in the clips area, all the videos that you 
most recently imported from your camcorder. Often, this is precisely what you 
want. 

• iPhoto	 Videos. Click this heading to see all the movie clips you’ve shot with 
your digital still camera (not your camcorder). In the Great iLife Master Plan, 
of course, it’s not iMovie that handles photos and videos from still cameras—it’s 
iPhoto (which you’ll learn about starting on page 72 of this appendix). So here, 
iMovie is giving you handy, one-click access to all the videos that you’ve imported 
into iPhoto from your still camera.

• 2010,	 2009,	 2008.... These year headings organize your camcorder video 
collection into annual clumps. Click a flippy triangle to expand or collapse a 
year heading so you can see all the video batches within it. These expanded 
lists actually show you all the individual import jobs you performed during 
that year, each with whatever name you gave it. If you click one of these Event 
names, the right side of the window displays all the video clips inside that Event.
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Hide the Projects or Events List
Once you’re well into working on a movie, you probably don’t need the list of 
projects staring you in the face. iMovie gets this. That’s why, as soon as you open a 
project, iMovie hides the list of projects, giving you more space for the storyboard 
itself. (You can always bring the Projects list back by clicking the Project Library 
arrow in the top-left corner of the iMovie window.)

You can hide the Events list as well, and for the same reason: because when you’re 
editing your Disney vacation video, you probably don’t need to be staring at a list of 
other vacation footage. This time, choose Window→Hide Event Library, or click the 
Show/Hide Events List button. The list goes away, and the video-clip area expands.

To bring the Event list back, repeat this procedure. You can also use the Hide and 
Show commands in the Window menu to hide or show the Project Library and the 
Event Library.

Adjust the Viewer Size
In iMovie, the Viewer is the playback window that sits in the upper-right corner of 
the screen. If you have a single monitor, the Viewer is always locked into the iMovie 
window. You can’t drag it around freely, but you can change its size. If you have more 
than one monitor, you can use the second one to show the Viewer in full-screen 
mode.
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To resize the Viewer, choose either Small, Medium, or Large from the Window→ 

Viewer submenu. Better yet, learn the keyboard shortcuts for the sizes so you can 
flip among them while you work: c-8, c-9, and c-0.

The advantage of a large Viewer is, of course, that you get the best view of your 
movie as you work. The disadvantage is that a large Viewer eats up screen space. On 
smaller screens, it squishes down the Events area so much that you have to do more 
scrolling.

Tip: For more gradations of size and control, you can resize the Viewer by dragging the central, horizontal 
iMovie toolbar up or down. Use any blank spot as a handle.

Swap the Two Clip Areas
When you first fire up iMovie, the storyboard area, where you actually build your 
movie, is fairly small. It’s wedged in between the Project Library and the Viewer.

The source-clips area, on the other hand, gets far more space, because it doesn’t have 
the Viewer to contend with.

As you work on your movie, therefore, you may wish that you could swap these two 
areas. You may wish that the storyboard could be the one with room to run, especially 
in the later stages of editing.

In that case, choose Window→“Swap Events and Projects,” or click the Swap button 
shown on page xx.

Editing in iMovie
Whether you’re working on a Mac or in a multimillion-dollar Hollywood profes-
sional studio, film editing boils down to three tiny tasks: selecting, trimming, and 
rearranging clips. Of course, that’s like saying there’s nothing more to painting than 
mixing various amounts of red, yellow, and blue. The art of video editing lies in your 
decisions about which clips you select, how you trim them, and what order you put 
them in.

When you get right down to it, iMovie boils down to two big storage places for video 
clips. There’s the Event browser, usually the bottom half of the screen, where all your 
raw, unedited video shots live. And there’s the storyboard, usually the top half, which 
is where you assemble and edit your masterpiece.

At its simplest, then, iMovie editing is all about this three-step process:

1.	 Review	your	video	in	the	Event	browser	and	find	the	good	parts.
2.	 Add	those	chunks	to	the	storyboard,	where	iMovie	plays	them	in	one	seam-

less	pass,	from	left	to	right.
3.	 Add	crossfades,	titles	(credits),	music,	and	effects.
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Review Your Clips (Skim + Play)
Video editing always starts out with a pile of raw, unedited footage. In iMovie’s case, 
that’s the bunch of clips in the Event browser. Click an Event’s name to see what 
video is inside. 

iMovie ’11 represents every imported camcorder shot with a filmstrip—a horizontal 
bar whose length represents the duration of the clip. The filmstrip is made up of 
individual sample frames from the clip.

Note: If a filmstrip is too wide for the iMovie window, it wraps around to the next line. A ragged filmstrip 
edge tells you that it’s been wrapped in this way. Think of that ragged edge as the video version of a 
hyphen.

Each of these frames represents, for example, 5 seconds of actual video. So a 30-sec-
ond video clip would appear as a filmstrip that’s six frames long:

Using the slider at the lower-right corner of the window, you can adjust the relative 
lengths of the filmstrips in your Event browser. An identical slider appears beneath 
the project storyboard area, meaning you can adjust the filmstrip lengths indepen-
dently of each other.

If you move the slider all the way to the right, every video clip is represented by one 
frame. The filmstrips’ relative lengths are no longer represented; every clip appears 
as an icon. This arrangement makes clips very easy to move around, resequence, 
and so on. It makes a very long movie fit on your screen without scrolling. (It also 
makes iMovie a lot more familiar if you’re used to working in previous versions of 
the program.)
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If you move the slider all the way to the left, each frame of the filmstrip represents a 
half second of video. At this position, you can actually make frame-by-frame edits.

Skimming
Skimming means moving your cursor across a filmstrip. Don’t drag, which would 
mean pressing the mouse button. Just point with the mouse. Move the cursor across 
a filmstrip without clicking or dragging.

The playhead—a vertical line the height of the filmstrip—moves along with your 
cursor. And as you skim, the Viewer window shows the underlying video playing 
back at high speed—or medium speed, or slow speed, depending on your cursor 
speed. (You also see the same video playing within the filmstrip itself, beneath your 
cursor.)

Skimming may take some getting used to, because it’s such an unusual computer 
technique; it’s probably the first time in history that moving the mouse without click-
ing has done anything besides, well, moving the cursor to a new spot. But it means 
that you can control not only the speed of the playback, but also the  direction— 
forward or reverse—in real time, almost effortlessly.

Skimming works anywhere fine filmstrips are found—either in the Event browser or 
in the project storyboard.

Playback
Skimming is great for quickly getting the gist of what’s in your captured clips. But 
unless you’re some kind of quasi-mechanical cyborg, you’ll find it very difficult to 
skim at exactly the right speed for real-time playback.

Fortunately, iMovie can also play back clips all by itself, at the proper speed. To do 
that, use the space bar on your keyboard as the start/stop control. Hitting space 
always begins playing video at the position of your cursor. And it always stops 
when you press space again.

Once you’ve mastered that difficult technique, you’re ready for the real gem: using 
skimming and playback together. It works like this: Point at a filmstrip with your 
mouse, skimming as you scan around, looking for the part you want to watch. When 
you get close to the right spot, tap the space bar. Playback begins from the precise 
position of your mouse.

Tap space to stop playback, then move your mouse to another spot, and tap the 
space bar again. In this way, you can jump around, spot-inspecting your clips, or 
even pieces of your clips, without ever touching the mouse button—and without ever 
having to wait.
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Tip: Actually, there are four other ways to play back a source clip or your movie in progress, complete 
with corresponding keyboard shortcuts:

• Play the selected chunk (/ key).

• Play from the beginning (\ key).

• Play the 2 or 6 seconds around your cursor ([ or ] key).

• Play full screen (c-G).

Select the Good Bits
The reason you’re reviewing clips in the Event browser, of course, is to find the good 
parts—the highlights, the pieces you want to include in your finished movie. Once 
you’ve selected a chunk of video, you can drag it into the storyboard to make it part 
of your movie.

Selecting comes in handy for other purposes, too. For example, you can designate 
part of a clip as either a Favorite (a snippet you know you’ll want to come back to 
later) or as a Reject (a worthless shot). These steps, too, require that you first select 
the piece of clip that you want to flag.

Since selecting is such a critical step in iMovie moviemaking, Apple made sure you 
had all kinds of different ways to make a selection. 

The first selection method is the one you’ll probably use the most often: dragging. 
That is, slide the cursor across some footage while pressing the mouse button, just 
the way you’d select text in a word processor. iMovie indicates which part of a clip 
you’ve selected by surrounding it with a yellow rectangle:

The bottom edge of the iMovie window shows you how many seconds’ worth of 
video you’ve highlighted, relative to the original clip. To choose a 4-second chunk, 
just click a filmstrip in the Event browser (without dragging). Your click marks the 
starting point; iMovie instantly selects the following four seconds of video.

Tip: You can change the factory setting of 4 seconds to any length between 1 and 10 seconds. To do that, 
choose iMovie→Preferences, and drag the “Clicking in Event browser selects” slider.
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Depending on the situation, you can select an entire clip in any of three ways:

• Option-click a filmstrip to highlight the whole thing.
• Click to select part of a clip, and then choose Edit→Select Entire Clip 

(c-A).
• If you never use that 4-second-clip-selection feature, you can tell iMovie that, 

whenever you click once on a filmstrip, it should select the whole thing. To 
do that, choose iMovie→Preferences, and then click the Browser tab. Turn on 
“Clicking in Events Browser selects entire clip” and then close the Preferences 
window.

Note: These instructions apply only to selections in the Event browser. When you click a clip in your 
project storyboard, you always select the entire clip.

To deselect whatever’s selected—that is, to take away the yellow border entirely—use 
any of these three techniques:

• Click anywhere in the dark-gray background.
• Choose Edit→Select→None.
• Press Shift-c-A.

Build the Storyboard
The project storyboard is the large work area that starts out at the top of the screen. 
The key to building a movie is moving your selected video bits from the Event 
browser into this storyboard.

Most people build movies by reviewing the raw footage from left to right—from 
beginning to end—and choosing bits, in sequence, to include in the edited mas-
terpiece. In such cases, you’ll want to add your selected clip(s) to the end of your 
storyboard.

iMovie offers two ways to do that. Select some video in the Event browser, and then 
do one of these things:

• Press the E key.
• Click the Add Selection button (it lives in the middle of the central toolbar and 

looks like a turned page with a little star on it).
• If you have a Mac laptop with a multitouch trackpad (for example, a recent 

MacBook or MacBook Pro), swipe upward on your trackpad with three fingers.
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In any case, you’ll see the selected chunk(s) of video fly from the Event browser to 
the end of your storyboard. To check the result, point to the storyboard (without 
clicking) just before the spot where the new video has landed, and then press the 
space bar.

Note: Each time you add some footage to your edited movie, iMovie slaps an orange stripe across the 
bottom of the original clip in the Event browser. That’s a reminder that you’ve used this segment in your 
project. As your work proceeds, you’ll be able to tell, with a glance at your Event browser, what proportion 
of the original video you’ve used in the finished opus.

Now, remember that all of your edited movies—your projects—draw upon the same well of source video 
on your computer. What’s cool, therefore, is that iMovie memorizes the orange striping for every project. 
If you’ve used a different set of Little League footage in each of three projects, for example, then you’ll see 
the stripes jump around in the Event browser as you click each project in turn.

Adding to the Middle
You don’t have to add selected video to the end of your storyboard. You can place it 
between two existing clips, smack in the middle of an existing clip, or even super-
imposed on a clip. These options are all part of a new feature in iMovie ’11 called 
“Advanced Drag and Drop.”  

To add a chunk of footage between two clips, drag the selected chunk (using any-
thing inside the yellow border as a handle) right into the storyboard. When iMovie 
displays a green vertical line indicating where the clip will go, release the mouse. The 
chunk of video slips right in between the surrounding clips.

If you drop your chunk on top of a clip in your storyboard rather than between clips, 
iMovie displays the “Drag and Drop” menu. Its options include Insert, which splits 
the underlying clip into two pieces and drops your chunk between them.

Don’t Remember to Save
You don’t have to save your work. iMovie ’11 automatically saves as you go. (It doesn’t 
even have a Save command.)

Fine-Tuning the Edit
Once you’ve got a rough cut of your storyboard, you may consider the Event 
browser a lot less necessary. Your work focus will probably shift to the storyboard 
from here on out. Now, in other words, might be a good time to hide the Projects 
list and move the whole storyboard to the wider space at the bottom of the iMovie 
window, as described on page 15 of this appendix.
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Storyboard Playback
You can use instant playback to spot-check your storyboard work in the Viewer win-
dow. Since you’ll probably be doing a lot of this, iMovie offers multiple techniques:

• Anyplace	playback. Point (without clicking) to any spot; press the space bar, or 
double-click, to begin playback. Press space again to stop.

• Selection	 playback. Make a selection. (Either click a clip once to select the 
whole thing, or drag across it to choose just part.) Then press the forward slash 
key (/, next to the period key) to play back just that selection from the beginning. 
Press / again to stop.

• One-second	 (or	 3-second)	 playback. Here’s a supremely handy new feature: 
You can tap the [ or ] keys to play back the 1 or 3 seconds, respectively, immedi-
ately before and after the position of your cursor. It’s sort of like a skim-and-play 
all at once.
If some video is highlighted with the yellow boundary, then these keystrokes 
play back either the first second (or 3 seconds) of the selection, or the last sec-
ond (or 3 seconds), depending on which is closer to your cursor.

• Whole-storyboard	playback. Press the backslash key (\, above the Return key) 
to play the entire storyboard from the beginning. Press \ again (or the space bar) 
to stop.

No matter how you started playback, you can always stop by clicking in the iMovie 
window or tapping the space bar.

Full-Screen Playback
You can make the Viewer window bigger to get a more detailed view of your video 
using the c-8, c-9, and c-0 keystrokes explained on page xx. But eventually, you’ll 
want to treat yourself to iMovie’s IMAX mode: full-screen playback. That’s when all 
the controls and menus of iMovie itself disappear, and the video fills your entire 
monitor. Here again, iMovie offers different approaches:

• Play	 from	 the	 pointer. Point without clicking to any spot in the storyboard. 
Then press c-G to begin full-screen playback of the selected video.

• Play	the	entire	storyboard. Click the Full-screen Playback button to play your 
storyboard from the beginning. Choosing View→Play Full Screen does the 
same thing.

Once full-screen playback is underway, just moving your mouse produces the navi-
gation strip shown below.
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Full-screen playback’s behavior is a little quirky, but here are the basics:

• Press the space bar to start and stop playback without exiting Full Screen mode. 
Or click the 2 button at the left end of the navigation filmstrip.

• During playback, click another spot in the navigation filmstrip to jump there 
and pause playback.

• During playback, double-click another spot in the filmstrip to jump there with-
out pausing playback.

• When you’ve paused playback, you can skim the navigation filmstrip (point 
without clicking) to explore the movie. Press the space bar to begin playback 
from any spot. 

• Switch to a different event/project by either clicking one of the other filmstrips 
in the “cover flow,” or by using the horizontal scrollbar underneath the clips.

When you’re finished with full-screen playback, click the ˛ button or press the Esc 
key to return to the iMovie window. (Or, if you wish that iMovie would exit full-
screen mode automatically after each playback, turn on that option by choosing 
iMovie→Preferences and visiting the General tab.)

Rearranging Video
Unless your last name is Spielberg or Scorsese—and maybe even if it is—the first 
place you put a clip in the storyboard won’t always be the best spot for it. Sooner 
or later, you’ll wish you could move shots around in the film. Fortunately, you can. 
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Here’s the secret: Just select the part you want to move, and then drag it to its new 
location. You can drop the dragged clip in between two clips in the storyboard, but 
not right in the middle of a clip. 

Dragging isn’t the only way to move footage around in iMovie; the Copy, Cut, and 
Paste commands (which all live in the Edit menu) can feel more precise. These 
commands are also the only way to copy edited footage from one project to another.

Shortening or Lengthening Clips
Suppose a clip is running too long in your edited movie. Fortunately, having mas-
tered the art of selecting a portion of a clip, as described earlier, you’re ready to put 
it to work. You can shave off some footage from only one end of your clip, or even 
right from the middle. All you have to do is highlight the footage you want to delete, 
and then press Delete.

If you want to trim some footage off both ends of a clip, it’s quicker to highlight the 
part in the middle that you want to keep. That is, highlight the part you want, and 
then choose Clip→“Trim to Selection.” (Or press c-B. Why B stands for “trim to 
selection” is for you to figure out.) When you use this command, what used to be the 
selected part of the clip becomes, in effect, the entire clip. The clip is shorter now, as 
a tap on the space bar proves.

Video Effects
It’s a funny thing that we’ll take pristine HD video and make it look old and grainy—
on purpose. But iMovie’s video effects, like the popular Aged Film effect, create a 
mood that you can’t really communicate in any other way. 

To apply video effects to any clip or photo in your project (even cutaways [page 46 of 
this appendix] and travel maps [page 31 of this appendix]), double-click the clip (or, 
if it’s already selected, by clicking the I in the middle toolbar) to open the Inspector 
panel. Then click the None button next to the Video Effect label.

The Inspector flips around, revealing a bunch of thumbnails that show what your 
clip would look like with the video effect applied (below). As you skim across each 
thumbnail, the preview window demonstrates the effect. To apply an effect, click its 
thumbnail. When the Inspector flips back around, click Done.
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You can’t make any adjustments to iMovie’s video effects as you could in previous 
versions of the program. If you don’t like the way an effect that comes from Apple 
looks, you’re out of luck.

To remove an effect, pull up the Inspector again, click the button that identifies the 
current effect, and then click the None thumbnail. The Inspector flips back around. 
Click Done.

Fast/Slow/Reverse
Whether you’re mimicking Chariots of Fire or Buddy Hall, you can add a lot to your 
movie by changing the speed of your footage. To make a clip play back faster or 
slower, double-click it to open the Inspector panel. You’ll see one of two things in 
the middle of the panel:

• Convert	Entire	Clip. iMovie can’t adjust the speed or direction of a clip unless, 
as it sits there on your hard drive, it happens to be in a particular file format 
(the Apple Intermediate Codec, in case you’re wondering). If you see the Con-
vert Entire Clip button, click it to make iMovie convert the clip and display the 
Speed slider (next bullet).

Note: The Convert Entire Clip conversion step isn’t necessary if you’re editing footage imported from an 
AVCHD camera. That’s because iMovie has already converted your footage into the AIC format.
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• Speed	 slider. If a clip is speed-adjustable (either you’ve already converted it, 
or it didn’t need conversion in the first place), you see a slider in the middle of 
the Inspector panel depicting a tortoise and a hare (below). Dragging the slider 
closer to the tortoise slows your clip; dragging it toward the hare speeds it up.

Right below the Speed slider is the Reverse checkbox. Turn it on to make the video 
play backward. 

Tip: Why film your kids playing in the back yard, when you can film them playing on the moon? iMovie’s 
Green Screen and Blue Screen effects let you superimpose your subjects on whatever background you 
can think up, just as they’ve been doing in Hollywood for decades. With a little preparation, you could film 
things that would otherwise be impossible to shoot. Check out http://tinyurl.com/3zldrma to get started.
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Improving Your Footage
Nobody’s perfect, so, iMovie give you lots of ways to improve your footage after 
you’ve imported it. 

Video Stabilization
Video stabilization takes your wobbly, handheld video makes it look like the super-
steady handiwork of a tripod-wielding pro. Unfortunately, this sort of analysis takes a 
very long time—roughly 10 minutes for every minute of video (more or less, depending 
on your Mac’s speed). The good news: you get to pick when iMovie does its analyzing. 
Here are your options:

• Stabilize	during	import. When you first bring footage into your Mac, iMovie 
offers to analyze the clips as described in the Tip on page 3 of this appendix.

• Stabilize	selected	clips. You can analyze certain clips at any time. Select one or a 
group of them, and then choose File→Analyze Video→Stabilization.

• Stabilize	 an	 entire	 Event. In the Event list, click an Event’s name and then 
choose File→Analyze Video→Stabilization.

Tip: If you want, you can choose “Stabilization and People,” which simultaneously handles the people 
analysis described on page 49 of this appendix. After all, if you’re going to wait for one, you might as well 
wait for the other.

• Stabilize	a	clip	in	the	Event	browser. Double-click a clip to open the Inspector 
panel, and then click Analyze Entire Clip.

Once iMovie analyzes a clip, it generally applies stabilization only when you add the 
clip to your project. If you want to preview the stabilization, select the clip in your 
Event Library, then right-click it and choose “Play with Stabilization Preview.” You’ll 
see the stabilized clip play back in the iMovie viewer.

Sometimes, your video comes out looking just a little too stable. You were running 
down a light of stairs while filming, for crying out loud—it should look a little like 
you were on foot, not like you were gliding down a sheet of ice. Fortunately, you can 
throttle back the amount of stabilizing that iMovie does by double-clicking the stabi-
lized clip to open its Inspector panel, and then adjusting the Maximum Zoom slider. 
If you change your mind and decide that a clip looks better without stabilization, 
open the Inspector panel, and then turn off the box that says “Smooth clip motion.” 
The shake comes back. And don’t worry about having to reanalyze footage if you 
change your mind yet again: Once analyzed, always analyzed.
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Color Fixes
iMovie can apply some awesome color-correction effects to your video, too. To get 
started, click the clip that needs help. iMovie does different things depending on 
where you decide to click the clip:

• In	the	Event	browser. If you click a raw source clip here, then the changes you 
make appear in every project that incorporates that clip.

• In	the	project	storyboard. If you click a clip you already placed in the story-
board, the changes you make affect that video in this movie only. The original, 
underlying source clip in the Event browser remains unchanged.

Once you select a clip, you see a still image of it in the Viewer window. Press the V key 
to open the Video Adjustments panel. If you’ve ever adjusted the colors of a picture in 
iPhoto (page xx), the panel’s controls should look familiar. They affect your video here 
exactly the same way they affect a digital photo in iPhoto.

Dragging the Video Adjustments panel’s Exposure, Levels, and Brightness sliders 
by hand is one way to address color imbalances in a clip. But there’s an easier way: 
iMovie can adjust all three sliders automatically. Just click the Auto button at the bot-
tom of the panel, and then watch the results in the Viewer. You’ll be stunned at how 
much better your camcorder video can look with this one-click trick.

Transitions
What happens when one clip ends and the next one begins? In about 99.99 percent of 
all movies, music videos, and commercials—and in 100 percent of camcorder movies 
before the Macintosh era—you get a cut. That’s the technical term for “nothing special 
happens at all.” One scene ends, and the next one begins immediately.

Professional film and video editors, however, have at their disposal a wide range of 
transitions—special effects that smooth the juncture between one clip and the next. 
For example, the world’s most popular transition is the crossfade or dissolve, in which 
the end of one clip gradually fades away as the next one fades in. The crossfade is so 
popular because it’s so effective. It gives a feeling of softness and grace to the transi-
tion, and yet it’s so subtle that the viewer might not even be conscious of its presence.

Like all video editing programs, iMovie offers a variety of transitions, of which 
crossfades are only the beginning.

Creating Individual Transition Effects
To see the 20 transitions iMovie offers, click the Transitions button, which is identi-
fied below. Point to a transition’s name (like Cross Dissolve) without clicking to see 
a small animated preview of it.
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Once you’ve found a good effect, drag its icon out of the Transitions panel and 
directly into the storyboard area, in the vertical gap between the two filmstrips 
that you want transitioned.

If you like the idea of a transition but you just don’t like the one you put there, drag a 
different one out of the Transitions panel right on top of the old one.

To get rid of a transition, even months or years later, highlight its icon and then press 
the Delete key. Your original clips return instantly, exactly as they were before you 
added the transition.

Automatic Transitions
If you’re really in a hurry to crank out your edited movie, like the now-legendary 
Apple programmer who wound up writing iMovie ’11 so he could whip out high-
light reels without hand-tweaking everything, then you’re in luck. You don’t have to 
bother placing transitions one at a time. Using the Automatic feature, you can tell 
iMovie to put the same, identical, fixed-length transition effect between all clips.

This feature is OK if all of this is true:

• You choose a nontacky transition effect, like the Cross Dissolve.
• You set the duration to something short, like 1 second.
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• You’re creating a highlight reel, a sequence of shots that aren’t intended to tell 
a story.

If you’re not careful, these frequent transitions can get annoying or cloying, and 
they’ll lose their impact in a hurry. You should also note that turning on the Auto-
matic feature removes any customization you’ve done using the individual-transi-
tion feature described on the preceding pages. All of your duration adjustments are 
wiped away.

Still interested? Then proceed like this:

1.	 Choose	File→Project	Theme,	or	press	c-J.
Either way, the Project Theme screen appears.

2.	 Turn	on	“Automatically	add.”	From	the	pop-up	menu,	choose	the	transition	
style	you	want.
This time, you don’t get the handy self-illustrating icons that show you what the 
effect will look like. It doesn’t matter; the only one you’d ever use without look-
ing amateurish is the Cross Dissolve. (Right?)

3.	 Click	OK.
You return to your project, where the icons for iMovie’s automatic transitions 
now appear in place. Play back the movie to enjoy the effect, keeping in mind 
that you can’t edit, change, or delete them individually, only en masse. 

Themes
Themes are sets of professionally designed and animated transitions and titles that 
run throughout your movie, usually including an opening-credit sequence, a special 
transition style, and a closing-credit sequence.

Any time you create a new project, iMovie gives you the chance to apply a theme to 
it. The new project sheet, shown on page 13 of this appendix, gives you previews of 
each theme filled with example footage so you know what your stuff will look like. 

If you choose a project theme, iMovie offers you transitions and titles available only 
to that theme. If you choose None for your theme, those transitions and titles don’t 
show up in your list of choices. On the other hand, if you choose a theme, you’re 
locked out from the custom stuff available in the other themes. (Maybe that’s for the 
best. Mixing themes could look pretty ugly anyway.)

Note: iMovie is very generous to the wishy-washy. Each theme has title and transition elements that 
correspond precisely to those in the other themes. So when you change to a different theme, iMovie 
just replaces elements from the old theme with the matching elements from the new one. To change a 
theme, choose File→Project Theme and click the new theme you want. Once you click OK, iMovie takes a 
moment to update all the corresponding elements. Everything else, like timing and the clips in the project, 
stays the same.
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You can adjust a theme transition’s length the same way you adjust a regular transi-
tion’s length: Point to the transition and click the F badge on it. From the menu that 
appears, choose Transition Adjustments. The Inspector pops up so you can type in a 
new duration (in seconds and tenths of seconds). Click Done.

But one of the coolest things about themes is that they incorporate your pictures and 
video into the neat animations that go between clips. The animated photo album, 
for example, displays your video and photos as though they were actual photos in 
the album. 

Tip: If you’re using the Sports theme, you can take it a lot further than just a few neato transitions and 
titles. Apple devised this slick, professional theme for presenting your sports (or sales) team to the world. 
Click here to learn more about it: http://tinyurl.com/3oowjby

You may come to realize that a particular project is worse off with a theme applied 
to it. If this happens, you can remove the offending theme. Click File→Project 
Theme; on the General tab, click None, and then click OK. iMovie sweeps away all 
the theme-related titles and transitions, leaving you with a decidedly less theme-y 
project. (Non-theme transitions, like cross dissolves, survive iMovie’s sweep.)

Travel Maps
Travel maps are basically animated maps that take viewers from Point A to Point 
B with a snaking, animated red line across a map or a globe, à la the Indiana Jones 
movies. They’re great for conveying your itinerary in a quick, visually compelling 
way. Although you might think of them as transitions—after all, they fill the space 
between things (in this case places) much as transitions do—iMovie doesn’t think of 
them that way. To iMovie, they’re specialized video clips.

To add a travel map, in the middle toolbar, click the globe icon to open the “Maps, 
Backgrounds, and Animatics” pane (above). You’ll see eight animated map options 
at the top of the list: a globe version and a flat version of four different map styles. 
You’ll also see non-animated versions of each map you can stick in your project as 
images. Adding an animated travel map to your project is a matter of dragging one of 
the eight icons into your project, just as you would a transition or video clip. 
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As soon as you drag a map icon into your project, the Inspector window appears. (If 
you don’t see it, point to the map clip and click the F badge. From the menu that 
appears, choose Clip Adjustments.) That’s fortunate, because the first order of busi-
ness is to change the endpoints of your new animated map. After all, showing your 
dramatic flight from Topeka to Tangiers is why you’re putting this thing into your 
movie to begin with. You can choose your departure and destination points from 
a list of hundreds of preset locations. To change a location, click the San Francisco 
button (or whatever it says next to Start Location). The Inspector flips around to 
reveal a huge list of cities and airports (below). You can winnow down the list by 
typing a destination’s name into the box at the top of the window. Click to highlight 
the desired location, and then click OK. Repeat the process for the End Location, 
and then click Done.
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Tip: If the list doesn’t offer the location you want, you can type in the decimal coordinates (for example, 
44.768056, –85.622222 points to Traverse City, MI). You can get these coordinates at www.itouchmap.
com/latlong.html. Then just edit the “Name to display” text at the bottom of the Inspector window.

If you started with a globe map and decide you prefer a flat one, or if you started 
with the Educational Map and like the Watercolor Map better, you can easily 
change it. Just drag a new map from the “Maps, Backgrounds, and Animatics” pane 
onto the map you want to replace. iMovie preserves locations and the length of the  
animation.

Note: If a map’s animation is too slow or too fast, you can adjust it by bringing up the Inspector and then 
clicking the I button in the middle toolbar. Type the duration you prefer, in seconds and frames, into the 
Duration text box and then click Done.

To remove a map, just select its clip icon in the storyboard and hit the Delete key.

Animatics
When professionals plan the filming of a movie, they typically create a storyboard: 
a shot-by-shot plan of everything in the movie, from the sweeping opening scene 
down to the shot of the hero tying his shoes. It looks a little bit like a comic strip. 
iMovie ’11’s animatics feature gives you a set of storyboard scenes so you can do your 
own version of what the pros do.  
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To add an animatic to your project, click the “Maps, Backgrounds, and Animatics” 
button in the middle toolbar of the iMovie window (flip back to page xx for help 
finding the button or just press c-5 to open the pane). Scroll down past the maps 
and backgrounds and you’ll see a bunch of black-and-gray images showing a variety 
of scenes: with people and without people, medium shots and wide shots, two people 
and many people, as shown below. 

Now just drag an animatic into your project like you’d do with a map or video clip. 
Continue adding animatics until you have the storyboard you want. You can move 
animatics around by dragging them and delete them by selecting them and pressing 
Delete.

Titles
Text superimposed over footage is incredibly common in the film and video worlds. 
You’d be hard-pressed to find a single movie, TV show, or commercial that doesn’t 
have titles, captions, or credits. In fact, one telltale sign that you’re watching an amateur 
video is the absence of superimposed text.

In iMovie, the term title refers to any kind of text: credits, titles, subtitles, copyright 
notices, and so on. To add one to your project, start by choosing Window→Titles 
(c-3), or clicking the T button just below the Viewer. The Titles panel appears, 
illustrating the different text styles available.
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Once you’ve chosen a title style, drag its icon directly into the storyboard. As you 
do, iMovie highlights the filmstrip you hover over in blue (as shown below). That’s 
iMovie’s way of helping you pinpoint where the text will first appear.
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As you see above, knowing where the title is going to land in your storyboard is 
extremely important. You’ll feel it snap into four places as your cursor moves:

• At	the	beginning	of	the	clip. As the blue highlighting illustrates, iMovie proposes 
covering the first 4 seconds of the filmstrip with the title. Placeholder text appears 
with moving video behind it.

• Over	the	middle	of	the	clip. If your cursor winds up here, the title covers the 
entire clip, beginning to end.

• At	the	end	of	the	clip. If your cursor falls here, the title stretches over the final 
four seconds of the clip.

• Between	 clips. Under normal circumstances, iMovie text gets superimposed 
over the video picture. Particularly when you’re creating opening or closing 
credits, however, you may want the lettering to appear on a black screen—a 
striking and professional-looking effect. In those cases, drag the title to the gap 
between filmstrips Once you place the title, iMovie opens a little pop-up win-
dow showing you different backgrounds for your text. Since you’re not putting 
words on top of a clip or image, you need to tell iMovie what to show behind 
your text. Click an item in the window to put it behind the text.

These are, of course, just starting points; you can always adjust a title’s placement or 
duration after you’ve placed it.

Adjusting the Timing
Once you drop a title into place, it turns into a blue stripe over the filmstrip. The 
stripe indicates how long the text appears on the screen. You can adjust this stripe 
in three ways:

• Adjust	the	starting	point by dragging the left end of the stripe.
• Adjust	 the	 ending	 point by dragging the right end of the stripe. (Adjusting 

either the left or right end of the stripe also changes its duration.)
• Move	the	entire	title by dragging any other portion of it horizontally.

Type the Text
Unless the name of your movie is “Title Text Here,” you’ll probably want to edit the 
dummy placeholder text of your newly born title. To do so, click the blue stripe in 
the storyboard to select it. In the Viewer, text boxes appear, ready to edit.

In most styles, you’ll actually see two text boxes: a main title and a subtitle. Just click 
inside one of these boxes to edit the dummy text. When you’re finished editing (and 
formatting, as described next), click Done in the Viewer.

Font, Size, and Style
iMovie’s creators are rather fond of Gill Sans, the typeface used in most of the title 
styles. It looks great, but it also looks like everyone else’s iMovie ’11 videos.
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Fortunately, you have a surprising amount of typographical flexibility at your 
command. The most basic style options are available in the Text menu. Start 
by highlighting the text you want to change by clicking the blue stripe of a title 
you’ve already placed into your project. Then use the Text menu (the pull-down 
that appears at the top of the window) to make adjustments. You can also select 
some text and then press c-T to open the Font panel.

Editing or Deleting a Title
Making changes to a title is easy:

• Change	the	starting	or	ending	points by dragging the endpoints of the blue 
stripe in the storyboard.

• Move	the	entire	title earlier or later in the storyboard by dragging its stripe left 
or right.

• Edit	the	text	or	 its	 typography by clicking the title’s blue stripe in the story-
board. The text boxes appear in the Viewer. Press c-T to open the Font panel if 
you need to change the color, font, or other typographical niceties.

• Delete	a	title by clicking its blue stripe and then pressing the Delete key.

Music and Sound
It’s true that the visual component of film is the most, well, visible. The household 
names are the directors and movie stars, not the sound editors, composers, foley 
(sound effects) artists, and others who devote their careers to the audio experience 
of film. But without music, sound effects (called SFX for short), and sound editing, 
even the best Hollywood movie will leave you cold and unimpressed.

Two Kinds of Audio
iMovie ’11 has lots of new audio-editing features, but adding in sounds still starts 
in the same place: plunking music or audio files into your storyboard in one of two 
ways:

• Background	music is a solid block of music that sits “behind” the clips in your 
project, playing through everything, no matter how you shuffle the video clips 
around. You can even line up a playlist of several songs; they play consecutively, 
with a nice crossfade between them.

• Sound	effects.	When you add a sound effect, you attach an audio file to a specific 
spot in your video. As you rearrange your clips during the editing process, the 
effect goes along for the ride.

Now, the following gets confusing, so read it slowly: There’s no difference at all  
between the kinds of audio that you can use in these two ways. Any audio, including 
sound effects, can be background audio; and any audio, including songs, can behave 
like a sound effect. You’ll learn the details later in this appendix.
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The Music and Sound Effects Browser
Here’s how you go about choosing a piece of music, or a sound effect, for your movie:

1.	 Choose	Window→Music	and	Sound	Effects	(or	press	c-1).
Alternatively, click the musical-notes icon just beneath the Viewer. Either way, 
the lower-right chunk of your iMovie window is now filled with the “Music and 
Sound Effects” browser.

2.	 Find	just	the	right	song	(or	other	sound).
The panel is filled with useful controls to help you find the right sound. Its 
listings include iMovie Sound Effects, iLife Sound Effects, GarageBand, and 
iTunes. To listen to a piece of audio in any of these categories click its name, 
and then click the 2 button beneath the list. Or, if you think life is too short 
already, just double-click a song’s name. You can sort the list alphabetically by 
song name, artist name, or song length just by clicking the appropriate heading 
above the list.

3.	 Drag	the	music	into	your	storyboard.
Using the song’s name as a handle, drag it directly out of the list and into the 
storyboard. Release the mouse when the song looks like it’s in the right place. 
If you release the mouse when the entire background of the storyboard has 
turned from its normal black to green, then you’re creating what iMovie calls 
background music; read on for details. If you release the mouse when the pointer 
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is on a filmstrip, then you’re creating what iMovie calls a sound effect, described 
on page 37 of this appendix.

Background Music
If you drag a piece of music into the background well of your storyboard—basically, 
anywhere except onto a clip—the background of the entire storyboard area develops 
a broad green bubble. That’s your clue that you’ve just installed a piece of what Apple 
calls “background music.”

Understanding what, exactly, Apple means by this term—and figuring out how 
it’s different from the sound effects–style music—isn’t especially easy. This much, 
though, is clear:

• Background	music	appears	in	the	storyboard. The music appears as a huge 
green or purple background bubble behind your filmstrips. (Sound effects 
audio, on the other hand, appears as a skinny horizontal stripe under the film-
strip.)

• The	music	ends	at	the	end	of	your	video,	even	if	the	song	isn’t	over. If the song is 
longer than your movie, a special vertical indicator bar appears after the last film-
strip to let you know. (It’s a vertical dotted line with two musical notes.) If you 
then add more video to the project, the background music expands to include it; 
it’s stretchy that way.

• Background	music	generally	plays	from	the	beginning	of	your	movie.	You can 
drag it into a different spot, however.
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• If	you	place	two	pieces	of	background	music	one	after	the	other,	iMovie	plays	
them	consecutively,	with	a	crossfade	in	between. You can add the second piece 
the same way you added the first one: by dragging its name from the “Music and 
Sound Effects” browser. (Two pieces of background music can never overlap, 
though.)

Sound Effects (Pinned Music)
Apple calls the other type of audio sound effects, and it’s specifically intended to be 
attached, or pinned, directly to a particular frame of a particular clip. If that clip gets 
pushed around in the storyboard during editing, the audio goes along for the ride.

There are three interesting things about sound-effects audio. First, it’s represented 
as a green horizontal stripe below the filmstrip. Second, you can attach more than 
one of these stripes, stacking them up as high as necessary. (That is, you can overlap 
these audio tracks, which you can’t do with background music tracks.) And finally, 
you can move, shorten, or delete the sound-effect stripes with a simple drag motion.

Editing Audio Volume
People will listen to your movie was much as they’ll watch it, so if you’re serious 
about making a great flick, it pays to spend some time getting the audio volume just 
right. Luckily, iMovie gives you two ways to do the job: the Audio Adjustments box 
and the rubber-band tool. In most cases, either feature will do the trick. However, 
if you want to adjust the volume of just one small part of an audio clip, you’re stuck 
with the rubber-band.
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If “rubber-banding” makes you think of office supplies instead of volume levels, then 
meet a little iMovie tool that’s super useful. (Audio editors call volume adjustments 
“rubber-banding” because the volume graph seems to stretch tight against the “start 
fade” and “end fade” points.)

To see the rubber-band tool, click the Show Audio Waveforms button below either 
your event footage or your project storyboard. A new set of horizontal tracks appear, 
representing the audio waveforms for everything in your project that produces sound. 
An identical-looking button appears under the Event Library; it opens a similar set of 
waveform tracks for the clips there.

Waveforms represent the volume levels of the audio. A single, thin line runs hori-
zontally across your waveforms, looking as though it wants to chop off their tips 
(above). That little line is the rubber-band tool. 

The height of the band determines the volume: the higher the line, the louder 
the clip. The starting position, about a third of the way down from the top, is the 
standard, 100% volume. If you drag the line higher or lower, iMovie provides a 
little floating window to show you how much you’re changing the volume.
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If all you could do was change the height 
of the line for the entire clip, there 
wouldn’t be much point to this whole 
new feature. The beauty of the tool 
comes in when you stretch it up or down 
on selected parts of your clips. This lets 
you soften the background music when 
Grandma Alice tells her (very) softly 
spoken story, for example. The key is to 
drag horizontally first to select the re-
gion you want to affect, and then to drag 
the rubber-band line within the selected 
area. You can see the line stretch up or 
down as you drag it. The middle image 
in the figure above shows this feature in 
action.

Note: Any volume adjustments you make in your 
project are project-specific. That is, other projects 
using those same clips don’t see (or hear) the 

changes. That’s not true, however, for volume changes you make to clips in the Event Library. Any volume 
changes to Event footage affect every project that uses that footage.

Abrupt changes in volume can be jarring, so iMovie automatically adds fades in (and 
out) when you adjust the sound level of a clip. You can see these fades as sloping 
grey lines to the right and left of the yellow-boxed section of the rubber band. If you 
want to change the length of the fade, to make it gradual or abrupt, grab the little 
yellow bubbles on either end of the volume adjustment and drag them horizontally, 
as shown in the bottom image above. Dragging them outward makes the volume 
change more gradually. Dragging them inward makes the volume change more sud-
denly, which you might do, for example, if you want the music to pop back in really 
loudly.

Note: You might have noticed that some of the waveform waves go above the rubber-band line, while 
most stay below it. That’s because the rubber band just sets the base volume for your clip. Every movie 
still has loud parts and quiet parts, no matter where you set the volume. The high peaks in your wave-
forms are the loud parts.

Your other option for adjusting audio is the Audio Adjustments Box. True to its 
name, this box lets you, well, make adjustments to the audio. To get started, double-
click any kind of audio: a background audio bubble, a purple narration stripe, a 
green sound effect stripe. In fact, you can even double-click a video clip, with the 
understanding that you’re about to adjust the camcorder audio’s volume. Whatever 
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kind of clip you choose, the Inspector window appears. Press the A key to summon 
the Audio Adjustments dialog box.

There are tons of tools in this box, but you’ll probably only ever need four of them:

• Volume	slider. Drag this slider to adjust the overall volume level of the selected 
clip. You can mute it entirely (by dragging the slider all the way to the left) or 
make it five times as loud (all the way to the right).
At this point, you can’t skim your filmstrips to hear the changes you’re making. 
Instead, to spot-check your work, click the filmstrip corresponding to the audio 
change you’re making. Drag the little red dot handle to position the playhead, 
and then press the space bar to start playback.

• Ducking. In the film business, lowering the music volume so that you can 
hear spoken dialogue is called ducking. What Apple is offering here is auto-
matic ducking. For example, suppose you’ve cluttered up your storyboard with 
so many background songs, crowd noises, and sound effects that you can no 
longer hear the dialogue in the original video. You can apply this option to the 
video itself (not one of the colored audio stripes or bubbles) to bring out the 
original filmed dialog. When you turn on this checkbox, you’re saying, “The 
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selected audio clip is the most important audio. I want to hear it above any 
other audio that’s going on.” This checkbox, in other words, makes all other 
simultaneous audio clips play softer. And using the slider, you can specify how 
much softer they get.

• Fade	 In,	Fade	Out. Ordinarily, you hear the audio for a sound or video clip 
immediately. But if you click Manual, you can create a graceful audio fade-in or 
fade-out for the selected clip—even if it’s a video clip from the camcorder. Use 
the slider to indicate how long you want that fading to take, in seconds (up to 
5 seconds).

• Normalize	Clip	Volume. You may not have much call for this button, but it 
can be handy now and then. It’s designed for situations when the clips in your 
project were recorded at different volume levels, resulting in some jarring 
unevenness during playback.
iMovie can normalize the clips, so that all of them have roughly the same volume. 
Just click the clips whose volume is out of whack, and then click Normalize Clip 
Volume. iMovie takes a moment to compute the clip’s new audio level. And then, 
just as a reminder that you’ve messed around with that clip, iMovie displays a 
tiny speaker icon (Í) near the beginning of it.

When you’re finished fiddling, click Done. The dialog box goes away, and you return 
to the movie.

Removing Audio Adjustments
As with all iMovie editing tools, the changes you make in the Audio Adjustments dialog 
box are nondestructive, meaning that you never actually change the underlying clips. 
You can undo or adjust your changes at any time, even years later.

Just click the clip you edited, press the A key, and then click “Revert to Original.” The 
clip now has its original audio levels back. Finally, click Done.

Importing Still Images
The more you work with iMovie and iDVD, the more you appreciate the conve-
nience of the way Apple has linked them to the other i-programs, like iTunes and 
iPhoto. Here’s a classic case:

When you open the Photos browser (shown below), or choose Window→Photos, or 
press c-2, you’re shown what amounts to iPhoto Lite: a scrolling panel of thumbnail 
images reflecting the contents of your entire iPhoto Library.
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Using the navigation panel just above the thumbnails, you can browse your photos by 
Event, album, folder, or according to the other iPhoto presets (like flagged photos or 
photos added in your last import). If you use Aperture, Apple’s pro photo-organization 
program, its library shows up here, too.

Adding photos to your project is a lot like adding music in that there are two ways to 
go about it. If you’re using photos from your iPhoto library or from the Finder, you 
add them the same way you add titles, as described earlier (page 35 of this appendix). 
That is, there are two places to drag photos: between clips, or onto them. The results 
are quite different.

If you drag a photo between two filmstrips in your storyboard, you create a new 
photo filmstrip (at top in the illustration here).
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In most regards, the photo now behaves exactly like a video filmstrip. You can crop 
it, rotate it, and make color adjustments to it, for example. You can also superimpose 
titles and credits on it.

Alternatively, you can drag a photo on top of a video clip (or photo filmstrip). At 
that point, the “Drag and Drop” menu appears (above, bottom image). If you aren’t 
inserting the photo or replacing something else with it, the most common and use-
ful command in this menu is Cutaway. When you use a photo as a cutaway, iMovie 
sticks it right on top of the underlying clip in the timeline. (It even casts a shadow 
on the clip below it).

A photo cutaway has three advantages over a photo filmstrip:

• It’s	much	easier	to	adjust. You can slide it left or right, earlier or later in the 
movie, with the touch of the mouse. And you can shorten or lengthen it just 
by dragging its ends. (Oddly, this last trick works only when the clip is not 
selected.)

• You	can	make	it	transparent. Because iMovie lets you adjust the transparency 
of a photo cutaway, you can dial it back, turning the photo into a translucent 
layer. You might take a photo of clouds, dial back the opacity, and—bam!—you 
have fog covering the clip underneath. To adjust the transparency of a photo 
you place in your project, double-click the photo to open the Inspector, and 
then drag the Opacity slider (below).
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• It’s	incredibly	useful. You’ve seen it a million times on TV. Someone starts talk-
ing; as the narration continues, the camera cuts away to a photo or another 
video clip; and then we return to the original person speaking. 
It’s actually pretty remarkable how easy iMovie makes this. Instead of having 
to extract audio from your video clip and then create a still clip to plug in the 
middle, you just drop a photo over the video and choose Cutaway. The result 
is a cutaway (with a cross dissolve, if you like) that looks like it took a lot more 
work than it actually did.

Keywords 
In iPhoto, keywords play an important role in helping you manage tens of thousands 
of photos.A keyword is a text label that you slap on a picture—a tag that will help you 
pluck that photo (and ones like it) out of a haystack later. If you’re consistent in using 
keywords, you can later round up all the photos bearing a certain keyword (“Casey,” 
say) with one click.

iMovie works with keywords as well, but you wouldn’t know it at first. To add keywords 
in iMovie, you need to turn on the Advanced Tools by going to iMovie→Preferences. 
On the General tab, turn on “Show Advanced Tools.” When you do, iMovie displays 
a button with an old-fashioned key icon on its central toolbar (below). Click it to 
open the Keywords window.
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iMovie starts you out with several sam-
ple keywords: Indoor, Outdoor, Land-
scape, and so on. To add your own, in the 
Keywords window, click the Auto-Apply 
tab. Then type a term in the Keyword 
box (lower-left) and press Enter. To edit 
a keyword’s name, double-click it. 

Note: Be careful—keywords are case-sensitive. 
iMovie treats kids and Kids as two different 
keywords.

iMovie gives you two ways to apply key-
words.

• “Painting”	 keywords	 onto	 clips. 
This method is wicked fast. It’s es-
pecially good if you want to apply 
the same set of keywords to a slew 
of different filmstrips—for instance, 
tagging all those shots from the ski 

vacation with “Family” and “Kids.” To do so, open the Keywords window, then 
go to the Auto-Apply tab. Turn on all the relevant keywords, then click your 
cursor and drag it across all the filmstrip sections that should get those key-
words. You’ll see a transparent blue layer atop the parts that you drag across. 
The parts of the clip with the blue layer get the keyword (s)—but the blue layer 
won’t cross over to a different clip: you have “paint” across one strip at a time.

• Select-then-apply	method. If you have a motley assortment of video and want 
to apply different keywords as you go, click the Keyword button, then click the 
Inspector tab. Select some video and then turn on the appropriate keyword 
checkboxes.

The next page explains how to round up all the shots that you’ve tagged with a cer-
tain keyword.

To remove keywords, highlight a clip and then, on the Inspector tab, turn off the 
keywords you don’t want. 
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People
The aptly-named People feature searches your footage for shots with people in 
them—sparing you the trouble of sifting through all those pans across majestic 
mountain landscapes when you’re looking for shots of your kid. (The feature can’t 
find specific people, like iPhoto’s Faces can). This is particularly useful when you go 
to make a trailer and iMovie asks you to furnish shots of living, breathing human 
beings. 

There are two ways to get iMovie to analyze your footage for people:

• Analyze	 when	 importing. When you copy footage from your camera into 
iMovie, the program can take a moment (all right, many moments) to scan 
all the new stuff for people. This option, described in the Tip on page 3 of this 
appendix, works great if you aren’t in a hurry to get editing.

• Analyze	in	the	Event	Library.	You can also start the analysis later, applying it to 
video you’ve already imported. Select an Event, or clips in an Event, and then 
choose File→Analyze Video→People. 

Once you set iMovie to work, it scans your footage for people. The process takes 
a while. As a rule of thumb, plan the analyzing to take about as long as the clip it-
self. Once iMovie finishes, all the clips bearing People keywords have purple stripes 
(people, purple—get it?). Double-clicking a purple stripe selects all the footage un-
der that stripe.

People Keywords
iMovie distinguishes clips by the number of people in a shot and their distance from 
the camera. Then it assigns special keywords to the clip based to what it finds:

• People. Identifies clips that depict people, no matter the number or closeness 
of the camera.

• One	Person,	Two	People.	Identifies how many people are in the shot.
• Group. Clips with more than two people in the frame.
• Closeup. Clips where the face(s) fill most of the video frame. Directors often 

use close-ups to convey the emotion of a moment.
• Medium.	Close enough to see a face clearly, but not close enough to see the 

person’s whole body.
• Wide. Long-distance shots where you can see a person’s whole body and every-

thing around him or her. Great for showing the scenery, but not for showing 
facial expressions.

The Keyword/People Filter
The payoff for painstakingly categorizing your footage with keywords and analyzing it 
for people comes when you need just the right clip, and you don’t have time to review 
the 6 hours of footage you took during your 11-day cruise. Choose Window→Show 
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Keyword Filter, or click the magnifying-glass button under the Event browser display. 
Either way, iMovie opens up a strange little keyword panel, wedged between the Events 
list and the Event browser. 

The times displayed down the right side are a cumulative tally of all the video in 
your library that bears each keyword. Even handier are the red and green pill-shaped 
things down the left side. These traffic lights affect what footage you see in the Event 
browser. When you click the green light, the browser shows only the clips marked 
with that keyword. The red light, naturally, has the opposite effect, hiding all clips 
with that keyword.

Tip: Clicking the keyword itself acts just like clicking the green light.  

By clicking the buttons below the list, you can manipulate what’s hidden and what’s 
visible in creative ways:

• Any	means “show me video with any of the keywords I selected.” If you turn on 
Vacation and Kids, for example, you see footage that has either of those key-
words applied.
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• All means “show me only the video that has all of these keywords.” If you turn 
on Vacation and Kids here, you see only footage to which you’ve applied both 
those keywords.

Movie Trailers
iMovie trailers are one- or two-minute long videos that look exactly like Hollywood 
movie previews, complete with swelling, majestic music; animated, flying title credits; 
and fast intercuts of scenes from the actual movie—only this time, they’re your footage 
from your life! If anything can make a casual acquaintances want to see your home 
movies, this is it.

To start a trailer project, choose File→New Project (c-N) or click the + button in 
the bottom-right corner of your project list. You’ll see a screen like the one shown 
below. Choose one of the trailer projects on the left (scroll down to see them all) and 
then click the Create button.

You’ll immediately notice that all your usual movie-making tools have been taken 
away. Instead, now you have a notebook with three tabs: Outline, Storyboard, and 
Shot List. You use these tabs to build your trailer. 
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Tip: It’s easy to spot the trailers you’ve created in iMovie’s Projects list; their icons look like movie tickets 
instead of the document icons used for regular projects.

The Outline
The Outline is where you type in all the basic information about your trailer (below). 
This is where you enter things like the name of your movie, your starring actor(s), 
and the credits.

When you move your cursor over each of the title sections in the Outline tab—
Name and Date, Cast, Studio, and Credits—the pane on the right previews how the 
title will appear with the stuff you type in. It’s a nice way to examine your change as 
you make them.

The Storyboard
The trailer’s Storyboard tab is where you do most of the work building your preview. 
It gives you pre-made slots into which you drop footage. You can also select the text 
of a scene header (in the image below, the headers are “And Dared to Scratch” and “A 
Cat”) and replace it with whatever you want.
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The Shot List
This tab shows all the shots that you need for your trailer. The list even shows each 
shot’s length in seconds:frames format. iMovie groups ’em by type (“Action,” “Land-
scape,” and so on) instead of by trailer sequence, as shown below. 

Tip: The shot list is useful as a planning tool. Print it out (File→Print) and then take it with you as you 
shoot your footage. (You can actually print any of the three tabs in your movie trailer project.) 
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Building Your Trailer
Now that you have the lay of the land (or skipped impetuously ahead for the  how-to), 
here’s what you do: 

1.	 Choose	File→New	Project	(c),	click	a	trailer	style,	and	then	click	Create.
Unlike themes, you can’t change a trailer’s style later if you change your mind, 
so choose carefully.

2.	 Fill	out	the	Outline	tab.
This is where you name your movie, cast, studio, and production staff.

3.	 Click	the	Shot	List	tab	to	review	the	kind	and	number	of	shots	you’ll	need.
Using the People feature (page 49 of this appendix) really helps find appropriate 
shots.

4.	 Click	the	Storyboard	tab	and	add	your	shots.
As you add each shot to each placeholder, iMovie automatically trims the clip 
to fit the allotted time.
If iMovie doesn’t frame a shot quite right—say it starts and stops at the wrong 
times—click the little blue box in the bottom-left corner of the clip. That brings 
up the Clip Trimmer, where you can choose a different section of the clip. You 
can’t, however, change the length of the clip; iMovie locks in each clip’s timing 
so that the cuts sync up with the trailer’s music and titles.

5.	 Fill	out	the	trailer	titles.
Each trailer uses custom titles that you can fill in with your own story. If your 
trailer portrays a boy with special powers embarking on an adventure of a life-
time, for example, the titles are a great place to tell that story. Click on a band 
of text in the Storyboard tab to change the title. (You might notice that some 
titles are separated into more than one text box. That’s because the trailer uses 
multiple font styles and sizes, and the boxes’ formatting is predetermined.)

6.	 Preview	your	trailer.
Click either the full-screen or regular preview buttons in the top-right corner of 
the Storyboard tab, and you’ll see your trailer in all its glory. At this point, you 
can customize things as explained in the box on the next page.

7.	 Share	your	trailer.
You share trailers just like you do regular projects, as explained in the next 
section.
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Customizing a Trailer
If you feel constrained by the limited editing available when 
you’re building a trailer, just convert your trailer into a regu-
lar iMovie project to get all the control you want. Choose 
File→“Convert to Project” and iMovie turns your promo 
film into a normal video project. The only minor difference: 

You can’t edit the stock titles that begin the trailer. (How-
ever, since you’re in regular project mode, you can delete 
the trailer titles and replace them with those of your own 
design.)

Exporting the Finished Movie
Your hard work is finished—now it’s time to show off! iMovie gives you lots of paths 
towards bragging rights, all tucked together in the Share menu. Here’s the rundown:

Exporting to Media Browser
The Media Browser holds movies, songs, and images so that other iLife programs 
can get to them easily. To send off your iMovie project, just select your project in the 
Project Library and then click Share→Media Browser. 

Exporting to iDVD
iDVD takes the movies on your computer and puts them on shiny discs you can 
watch on TVs. Before you grab your remote and popcorn, click your movie in the 
Project Library, then choose Share→iDVD. Page 59 of this appendix will guide you 
from there.

Up To Speed

Online Video Accounts (and iMovie)
iMovie gives you lots of ways to put your project online, 
but you need an account for any website where you’ll post 
your video. Head to YouTube.com, Facebook.com, Vimeo.
com, Me.com (for MobileMe), or ireport.cnn.com to set 
one up. 

Once you’ve gotten set up on one of these websites, you’ll 
need to tell iMovie your account info. The first time you 
choose a website’s name in the Share menu, iMovie opens 
a window that looks something like the one shown below—

only the Account box is empty. Click Add (to the right of the 
Account box) to tell iMovie your username and password. 

Once you enter your account info and share a movie to 
a website, iMovie will display the site’s logo next to your 
film in the Project Library so you know that video is online.

To take down a movie you’ve posted online, select it in the 
Project Library, click Share→“Remove from,” and then pick 
the site where it’s posted.
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Exporting to MobileMe
If you have a MobileMe account, you can post your video on a special video-
gallery page for all to see. Choose Share→MobileMe to post a movie from the 
Project  Library.

Posting to YouTube
Choose Share→YouTube. Log in with your YouTube account, add a name and 
description for your movie, and off you go.

Exporting to Facebook
Show your masterpiece to all your friends: Choose a movie, then click 
Share→Facebook. When you’re asked to pick a video size, go with one of the smaller 
ones. Long videos can take a while to upload and Facebook has restrictions on how 
much video you can post. If you have trouble uploading your video, it’s probably too 
big. Check out http://tinyurl.com/287tt8k for the technical details. 

Exporting to Vimeo
Vimeo.com is a lot like YouTube, only it tends to attract higher-quality, fancy-pants 
videos. Send your little project to this elite digital enclave by clicking Share→Vimeo. 
You’ll need to provide your account password, plus give your movie a title and specify 
who can see it using the “Viewable by” box. 

Exporting to CNN iReport
These days, everyone’s a journalist. So if you see something newsworthy, don’t get 
scooped by Wolf Blitzer. Just take pictures with your camera or phone, load every-
thing into iMovie, then and shoot your finished dispatch over to CNN iReport, a 
site that compiles and edits “citizen journalism.” To take a crack at the Pulitzer, click 
Share→CNN iReport. Then enter your iReport password and a title for your story. 
You’ll need to pick a video size (as always, smaller is better for sharing online) and 
then, when you’re ready, click publish. One word of warning: Once you put your 
video on CNN iReport, it’s hard to get it down (see the Note below for more info).

Note: If posting your video online seemed like a great idea at the time but now seems like, well, maybe 
not such a great idea, you use iMovie to take it down by clicking on the shared film in the Project Library 
and then going to Share→“Remove from YouTube” (or Facebook, or whatever). iMovie then opens up 
Safari and takes you to that website so you can remove the clip. 

One heads-up: You’ll have to contact CNN iReport and ask them to take down your video (you don’t 
automatically get the right to take it off their site)—so be careful what you post!

http://tinyurl.com/287tt8k
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Exporting as a QuickTime Movie
You guessed it: Select a movie, and then click Share→“Export using QuickTime.”

Exporting to iPod, iPhone, and so on
The steps for exporting a movie to an iPod, iPhone, iPad, Apple TV, or Front Row 
are nearly identical. All of them involve exporting the movie to iTunes which is the 
loading dock for all those gadgets and Front Row. The only difference is the size of 
the movie you create:

1.	 When	 your	 project	 is	 ready	 for	 prime	 time,	 select	 it	 and	 then	 choose	
Share→iTunes.
The “Publish your project to iTunes” dialog box appears (below). You’ve prob-
ably never seen a dialog box quite like this one.

In essence, it’s offering you various screen sizes for exporting your finished 
movie. The little blue dots indicate which sizes are appropriate for which kinds 
of gadgets. For example, the iPhone 4’s screen measures 960x640 pixels, so 
you’d select the Large option to send your movie to iPhone-owning friends. A 
standard-definition TV set has 640x480 pixels, which is why the chart offers 
Medium as an option for Apple TV playback. And because you can connect an 
iPod to a TV for playback, you see the Medium option listed there, too.

2.	 Turn	on	the	checkbox	that	corresponds	to	the	size	you	want	to	export.
You can actually turn on more than one of these checkboxes. You’ll wind up with 
several copies of this video.
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3.	 Click	Publish.
Now the time-consuming exporting and compression process begins. Feel free 
to switch into other programs—check your email or surf the web, for example—
while iMovie crunches away in the background. A progress bar lets you know 
how much farther iMovie has to go.

When it’s all over, iTunes opens by itself. If you click the Movies folder, you’ll see the 
new exported movies nestled there. They’re named after the project and the size you 
exported. For example, you might see “Birthday Party – Mobile” and “Birthday Party 
– Medium.” Once your movies are in iTunes, getting them onto your iPod, iPhone, 
iPad, Apple TV, or copy of Front Row works just like it always does.

iDVD ’11
Don’t look now, but Apple thinks that the era of the DVD has passed. iDVD, accord-
ing to Steve Jobs, is “for people who still want to make DVDs.” (His subtext: “Those 
losers!”)

The real action, he believes, is on the Internet.

But don’t tell that to the 120 million U.S. families who don’t have high-speed Internet 
access—or any Internet access at all—and therefore can’t see online video. These 
people aren’t on YouTube. They can’t see your .Mac gallery.

They almost certainly have DVD players, though. And producing your movies on 
DVD offers a wealth of benefits: They’re small, light, and easy to mail. DVDs can 
last a long time—a century, if you believe the manufacturers—if you stick to brand-
name blanks like Verbatim and Imation, and keep the burned discs in a cool, dry 
place.

iDVD—the program, the legend—turns iMovie movies and iPhoto slideshows into 
Hollywood-style DVDs that people can watch on TV sets. iDVD is where you design 
DVDs’ main menu screens, add playback controls, and otherwise dress up iMovie 
movies, resulting in dynamic, interactive DVDs that look amazingly professional. 
iDVD handles the technology; you control the style.

Phase 1: Export from iMovie
iLife programs are meant to work together, so getting your finished films from 
iMovie ’11 to iDVD is really simple. In iMovie, just pick Share→iDVD. Your com-
puter opens up iDVD and plops your finished iMovie masterpiece into a brand-new 
iDVD project. 

Note: In iDVD, the term “project” refers to a DVD that you’re designing: it’s different than an iMovie 
project. 
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Phase 2: Design the Menu Screen
The design of the DVD menu screen that’s now before you is based on a theme: a 
unified design scheme that governs how the menus look and behave, complete with 
attractive backgrounds, coordinated typography, and background music. 

iDVD ’11 offers over 30 of these themes. Each theme family contains a main menu 
screen, a chapter navigation screen, and an “extras” screen for bonus DVD features 
you can build with iDVD.

It takes a lot of individual design decisions to make a theme. For example:

• Background	image	or	video. Whatever art appears in the background, whether 
still images or video clips, is part of the theme. The movement of the desert in 
the Anime Pop theme is one example of video in action.
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Tip: Many themes include looping animations; many have music, too. The Motion button (‡) turns 
the animation and music on and off while you’re working on a DVD. (It doesn’t affect the finished DVD, 
however.)

• Button	type. The buttons in an iDVD project can be either little graphics or text 
phrases that your audience will click with the remote control.

• Button	look. The look of your buttons can vary. Text buttons may have simple 
backgrounds; graphic buttons may have borders.

• Button	positions. Each menu can accommodate up to 12 buttons, depending 
on the theme you’ve chosen, and you can’t change the buttons’ positions. 

• Drop	zones. Drop zones are areas into which you can drag a favorite video clip 
(sometimes more than one) that plays continuously in the background of the 
main menu screen. If you’ve ever seen a commercial Hollywood DVD movie, 
you’ve seen this effect: One key scene from the movie plays over and over, loop-
ing until you choose one of the buttons on the menu screen—or go quietly in-
sane. Dynamic drop zones can even move across the screen, passing in front of 
each other, providing amazing visual effects.

• Text	boxes. Text boxes let you freely add text blocks to your menu screens. You 
could use one, for example, to provide instructions to your viewers, copyright 
notices, or details about what they’re about to see.

• Font	selections. Themes also specify the color, font size, and typeface for menu 
titles and buttons.

Choosing a Theme
iDVD ’11 starts up with the very cool-looking, high-tech theme called Revolution, 
but goodness knows, you’re not stuck with that one. A wide range of canned themes 
awaits your inspection. To see them, make sure that the Themes button is selected in 
the program’s lower-right corner. Then choose a theme set from the pop-up menu at 
the top of the Themes pane.
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Within most themes, you can click the flippy triangle to reveal the screens that make 
up a theme family—complementary menus for the scene-selection screen, DVD ex-
tras page, and so on. Scroll through the list of themes, clicking each one to see what 
it looks like in the main work area, or just rely on the little thumbnail icons to get a 
sense of the theme’s overall flavor.

Note: All of the themes in the 6.0 and 7.0 collections appear, at first, to be suitable only for widescreen 
DVDs.

If you’re making a standard 4:3 DVD, then every time you click one of these themes, a warning box ap-
pears, asking if you really want to change the project to 16:9. That gets annoying fast. (Yes, you could turn 
on “Do not ask me again,” but then iDVD will switch to widescreen format without asking you.)

So for best results in looking over the themes, do so in widescreen mode, just to avoid being interrupted 
by that warning. You can always switch to the 4:3 version of a theme later by choosing Project→“Switch to 
Standard (4:3).”

When you click a theme’s thumbnail, iDVD asks if you want to apply the theme 
family to the entire project, so that the main menu and the Scene Selection menus 
match; almost always, this is what you want.

When you’re happy with the way the new theme looks, you’re ready to proceed with 
your iDVD design work. Fortunately, you don’t have to commit to a theme now; you 
can swap in a different theme at any time until you actually burn the DVD.

Drop Zones: The Basics
Drop zones let you use video, slideshows, or stills as the backgrounds of your menu 
screens. They’re purely decorative, designed to entertain your audience as they study 
their menu choices. (You add these videos or pictures by dropping them into the 
designated zones in the menu design—hence the name.)

Not every theme offers drop zones, but most of the iDVD 5, 6, and 7 themes do. As 
if you couldn’t guess, the words “Drop Zone” indicate where the drop zones are, as 
shown below.

Note that not all drop zones may be onscreen at once; the drop zones in several 
themes take their time in parading onto the screen, or rotating through it. To see 
all the drop zones in your chosen theme, click the Open Drop Zone Editor button 
below the screen. 
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iDVD gives you four different ways to fill these empty gray spaces with videos and 
pictures:

• Drag	directly	into	the	full-size	rectangle. Most of the time, you’ll be dragging 
videos or pictures from the Media Browser, a central repository of movies, pho-
tos, and music files on your Mac. (Click the Media button at the lower-right 
corner of iDVD, and then click either Photos or Movies at the top.)

• Drag	onto	the	drop	zones	in	the	Drop	Zone	editor. To open the Drop Zone ed-
itor, click the Open Drop Zone Editor button shown above. Thumbnails appear 
beneath the menu screen with dotted lines, all present and accounted for, so that 
you don’t have to wait for them to cycle into view in the main display window.

• Let	iDVD	fill	the	zones. Choose Project→Autofill Drop Zones and iDVD loads 
photos or movies—of its choosing—into the drop zones automatically.
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• Choose	a	picture	or	movie	on	your	hard	drive. Control-click (or right-click) 
a drop zone; from the shortcut menu, choose Import. Find and open a movie, 
slideshow, picture, or folder full of pictures, and iDVD uses that material to fill 
the drop zone.

If you’ve put a video into a drop zone and it doesn’t seem to be playing, click the Mo-
tion button (‡) at the bottom of the iDVD window or press c-J to play drop-zone 
clips. (Turning off Motion also turns off any background audio track and brings 
motion menus and motion buttons to a standstill.)

Note: The status of the Motion button has no effect on the final DVD, which always shows the animations 
and plays the music.

Phase 3: Add Your Movies
When you get right down to it, all iDVD really does is add window dressing—menus, 
buttons, and so on—to movies, music, and photos created in other programs.

You can bring movies and photos into your DVD in any of these ways:

• Choose	File→Import. You’re invited to choose any video, audio, pictures, and 
background movies onto whatever menu screen you’re editing.

• Drag	from	the	Finder. Another great way to install a movie into an iDVD menu 
screen is to drag it there, either right off the desktop or from an open folder 
window.

• The	Media	Browser. Dragging files in from the Finder is great, but it assumes 
that you know where your movies are. Fortunately, if you’re a little fuzzy on 
where you’ve stored all your movie files, iDVD can help. Click the Media but-
ton, and then click the Movies button at the top. Drag a movie from the list onto 
your DVD menu.

Tip: The Media Browser shows the movies in your Movies folder. But you can also tell iDVD to list the 
movies it finds in other folders on your Mac, too. Choose iDVD→Preferences, click the Movies tab, click 
Add, and then navigate to and select the additional folder you want it to monitor for movies. Repeat for 
additional movie folders.
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Phase 3.5: DVD Slideshows
The DVD may be the world’s best de-
livery mechanism for digital photos. 
Your friends sit there on the couch and 
click the remote control to walk through 
your photos (or, if you choose, they let 
the slideshow advance automatically). 
Instead of passing around a tiny pile of 
fragile 4 x 6 prints, your audience gets 
to watch the photos at TV-screen size, 
looking sensational—accompanied by a 
soundtrack of your choice.

In iDVD, you can incorporate movies 
into your slideshows. Sure, this feature 
may seem to violate the very definition 
of a slideshow, but whatever—the ability 
to mix stills and videos adds a lot to the 
visual record of your life.

If you’ve added movies to an iDVD 
menu screen, adding photos will seem 
like a piece of cake. Once again, you can 
do so using several different methods, 
each with its own advantages:

• iPhoto	 albums. Click Media, then click Photos. iDVD presents your entire 
iPhoto picture collection, complete with the albums you’ve used to organize 
them. The great thing about this system is that iPhoto albums contain well-
defined image progressions. That is, you presumably dragged the photos into 
an emotionally satisfying sequence. And that’s exactly how iDVD presents the 
pictures—as they appear in the album, from the first image to the last. Unfor-
tunately, iLife pulls off this trick by taking your iPhoto slideshow, wrapping it 
into a video, and then passing it to iDVD. That means that you won’t be able to 
make changes to your so-called slideshow in iDVD using the Slideshow Editor 
(iDVD’s tool for managing slideshows, explained below). 

• Folder	drag-and-drop. If the pictures you want to add aren’t in iPhoto, you can 
drag a folder full of them right off the desktop (or from a Finder folder) and 
onto an iDVD menu screen. With this method, iDVD creates a slideshow from 
the images, all right, but puts them into an unpredictable sequence.

• Slideshow	Editor. iDVD features a special window called the Slideshow Editor 
(explained next), where you can add individual photos to the slideshow and 
drag them into any order you like. This approach takes a little work, but it gives 
you the freedom to import images from many different sources without having 
to organize them beforehand.
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Tip: A DVD slideshow (any DVD, not just those produced by iDVD) can contain a max of 99 slides, and 
one DVD can contain a max of 99 slideshows. The designers of the DVD format obviously recognized that 
there’s a limit to the patience of home slideshow audiences.

The Slideshow Editor
No matter how you got your slideshow into iDVD, you edit it the same way: by 
double-clicking the drop zone to open iDVD’s Slideshow Editor. Once there, double-
click the Drop Zones icon to call up the Slideshow Editor’s editing screen.

Note: you won’t see the Slideshow Editor if you import a slideshow from iPhoto; see the “iPhoto albums” 
bullet above for details.

To add new pictures to the slideshow, use the following techniques:

• Drag	from	the	Finder. Drag an image, several images, a folder of images, or 
some movies directly into the slide list.

• Click	Media	in	the	bottom	right	of	the	main	iDVD	window,	and	then	click	
Photos	or	Movies. Drag a picture, a set of several shots, an iPhoto album, or a 
movie into the slide list.
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• Import	an	 image. Choose File→Import→Image. Navigate to any picture file, 
select it, and then click Open.

To remove a picture or movie from the list, just click it and then press the Delete key. 
To remove several images, Shift-click or c-click them to select the ones you want to 
get rid of and then press Delete.

To change the sequence of slides and movies, just drag them around. Once again, 
you can select multiple thumbnails at once and then drag them en masse.

Slideshow Settings
iDVD offers some useful options when you click the Settings button at the bottom 
of the Slideshow Editor window:

• Loop	slideshow. If you turn on this checkbox, the slideshow repeats until your 
viewer presses the Menu or Title button on their remote control.

• Display	navigation. When you check this option, you’ll see navigation arrows 
on the screen as your slideshow plays. Your viewers can click these buttons with 
their remote controls to move back and forth within your slideshow.
Being able to navigate your slideshow gives your viewers a feeling of flexibility 
and control, but you may consider the majesty of your photography marred by 
the superimposed triangle buttons. If that’s the case, leave “Display navigation” 
unchecked; your audience can use the < and > buttons on their remote controls 
to navigate. 

• Add	image	files	to	DVD-ROM. When iDVD creates a slideshow, it scales your 
photos to 640×480 pixels. That’s ideal for a standard TV screen, which, in fact, 
can’t display any resolution higher than that. But if you intend to distribute your 
DVD to somebody who’s computer savvy, you may want to give them the origi-
nal, full-resolution photos. They won’t see the high-res version of these photos 
when they insert the disc into a DVD player. But when they insert your DVD 
into their computers, the DVD works as a disc with files on it and they’ll see 
a folder filled with the original, high-quality photos, which they can use for 
things like printing, using as Desktop wallpaper, and so on. (In other words, 
you’ve created a dual-format disc that’s both a DVD-video disc and a DVD-
ROM.)

• Show	Titles	and	Comments. You can add comments for each image in your 
slideshow—and then, at your discretion, have them appear onscreen during the 
slideshow.
When you click Settings and then turn on “Show titles and comments,” you’re 
telling iDVD to display photo names and comments both in the Slideshow Edi-
tor and on the TV screen when the DVD plays. Once you do that, you can click 
the gray “Add comments” text below each slide title to add your custom text.
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Other Slideshow Editor features include:

• Slide	Duration. Use this pop-up list to specify how much time each slide spends 
on the screen: 1, 3, 5, 10 seconds, “Fit to Audio,” or Manual. 
Manual, of course, means that your audience has to press the Next button on the 
remote control to change pictures.
“Fit to Audio” appears in the pop-up menu only after you add a song or playlist 
to your slideshow. If you do, iDVD determines the timing of your slides auto-
matically—by dividing the length of the soundtrack by the number of slides in 
your show. In other words, if the song is 60 seconds long and you’ve got 20 slides 
in the show, each slide sits onscreen for 3 seconds.

• Transition.	You can specify how one slide morphs into the next with any of 
several graceful transition effects—Dissolve, Cube, and so on. Try each style 
by selecting one and then watching your slideshow. (Click 2 to start the show; 
click it again to return to the editor.) Viewing just a few slides shows you how 
the transitions work.
The transition you specify here affects all slides in the show; you can’t set transi-
tions on a slide-by-slide basis. Note, too, that transitions add to the time your 
slides spend on the screen. If you’ve chosen 3 seconds for the slide duration, 
each slide will actually hang around for nearly 5 seconds, when you consider 
the time it spends morphing.

Slideshow audio
Music has a profound impact on the effect of a photo slideshow. You can’t appreciate 
how dramatic the difference is until you watch the same slideshow with and without 
music playing.

The easiest way to add music to a slideshow is to click Media, and then click the 
Audio button at the top of the pane. Conveniently enough, iDVD shows your entire 
iTunes music collection, complete with any playlists you’ve assembled, as well as any 
GarageBand pieces you’ve composed.

When you find suitable musical accompaniment, drag its name out of the Garage-
Band or iTunes list and onto the Audio well. You can even drag an entire playlist into 
the well; the DVD will play one song after another according to the playlist, so that 
the music won’t die ignominiously in the middle of the slideshow. You can also drag 
a sound file from any Finder window or the desktop onto the Audio well.
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Tip: When it’s empty, the Audio well looks like a small speaker (ß). When it’s occupied, its icon identifies 
the kind of audio file you’ve installed; the little icon says, for example, AIFF, AU, or MP3. The icon used 
when you add a playlist rather than a single song varies, usually showing the first file type used in the 
playlist.

To try out a different piece of background music, drag a new song or audio file into 
the Audio well. And if you decide that you don’t want music at all, drag the file icon 
directly out of the Audio well and onto any other part of the screen. An animated 
puff of smoke confirms your decision.

To return to iDVD’s menu editor, click Return at the bottom.

Phase 4: Burning Your DVD
You’re almost ready to burn the DVD. But before you go using up a blank disc, test it 
to make sure that it works on the virtual DVD player otherwise known as your Mac.

iDVD’s Play button (2) lets you test your DVD to avoid unpleasant surprises. It en-
ters Preview mode, which simulates how your DVD works on a standalone set-top 
DVD player. You even get a simulated remote control to help you navigate through 
your DVD’s menus, movies, and so on, as shown here.
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To return to iDVD’s edit mode, click Exit or Stop (8).

Tip: Instead of using the arrow buttons on the remote to highlight and click screen buttons, just use your 
mouse. You’ll find it’s not only less clumsy, but also a decent indication of how your DVD will play back on 
computers that can play DVDs.

The Burn
When you’ve finished editing your disc and testing it thoroughly, it’s time to proceed 
with your burn. This is the moment you’ve been waiting for:

1.	 Choose	File→Save	Project	(c-S).
This might be a good opportunity to confirm that your hard drive has some 
free space, too. It needs twice the amount of free space that your project itself 
takes up.

2.	 Click	the	Burn	button	twice.	Insert	a	blank	DVD	when	the	Mac	asks	for	it.
Be sure you’re using the correct kind of disc for your DVD burner. For example, 
don’t attempt to burn 1x or 2x blanks at 4x speed.
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3.	 Wait.
It can take iDVD a very long time to process all of your audio, video, and photos, 
encoding them into the proper format for a DVD. Your wait time depends on 
how complex your project is, how fast your Mac is, and which encoding setting 
you’ve chosen. The bottom line is that this period is usually measured in hours, 
not minutes.
For best results, make sure that no other programs are busy—downloading 
email, playing iTunes music—while you burn a disc. A busy computer may 
introduce video glitches (like dropped frames) during the burn. Eventually, 
though, a freshly burned DVD pops out of your drive.

Tip: After your new DVD pops out, a message says, “Your disc has been created. If you want to create 
another DVD, insert another disc now.” Sure enough, if you want to spin out multiple copies of your 
project, you can insert another blank DVD right then, so that iDVD can record it without having to repeat 
all that time-consuming encoding. 

iPhoto ’11
Once you’re hooked on using a digital camera, your free, filmless photos pile up 
quickly. Before you know it, you’ll have 24,000 pictures of your kid playing soccer. 
Just organizing and keeping track of all those photos is enough to drive you insane.

Apple’s answer to these problems is iPhoto, a simple and uncluttered program de-
signed to organize, edit, and distribute digital photos without nightmarish hassles. 
Here’s the executive summary of iPhoto ’11.

Importing Pictures
Plugging a USB-compatible camera into your Mac is the easiest way to transfer pic-
tures into iPhoto. The whole process practically happens by itself:

1.	 Connect	the	camera	to	one	of	your	Mac’s	USB	jacks,	and	then	turn	the	camera	
on.
If iPhoto isn’t already running when you make this connection, the program 
opens and springs into action as soon as you switch on the camera.
A wonderful thing happens when you connect the camera: after a long (some-
times really long) pause, you get to see thumbnails (miniature images) of all the 
photos on your camera’s memory card.
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These thumbnails are super helpful. First off, they help you see what’s on the 
card. You don’t have to sit through the time-consuming importing process just 
to discover, when it’s all over, that you grabbed the wrong card or the wrong 
camera.
Second, you can choose to import only some of the pictures. (Select them by 
c-clicking, Shift-clicking, or drag-selecting, just as you’d do with Finder icons.)

2.	 If	 you	 like,	 type	 in	 an	 Event	 name	 and	 description	 for	 the	 pictures	 you’re	
about	to	import.
An Event, in iPhoto’s little head, is something you photographed within a cer-
tain time period (for example, on a certain day or during a certain week).
In the bad old days, iPhoto just imported everything on your memory card, 
and displayed all of those pictures in one gigantic clump—even if they included 
photos from several different events, shot weeks apart. Now, during the import-
ing, iPhoto automatically analyzes the time stamps in the incoming photos, and 
put them into individually named groups according to when you took them.
Your job here is to type a name for the event whose photos you’re about to 
import. It could be Disney Trip, Casey’s Birthday, or Baby Meets Lasagna, for 
example—anything that help you organize and find your pictures later. (Use the 
Description box for more elaborate textual blurbs, if you like. You could specify 
who was on the trip, the circumstances of the shoot, and so on.)
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Tip: See the Split Events checkbox at the bottom of the iPhoto window? If you turn it on, then iPhoto will 
auto-group the imported pictures into Events, as described above; you won’t, however, be offered the 
chance to name the Events (except for the first one) until after the importing is over. If this box is turned 
off, then all the photos will end up in one giant Event. (You can always split up this one giant batch into 
Events later.)

3.	 Click	the	appropriate	button:	Import	Selected	or	Import	All.
If you selected just some of the photos in step 1, then the Import Selected button 
springs to life. Clicking it brings only the highlighted photos onto your Mac, 
and ignores the rest of the camera’s photos. If you click Import All, well, you’ll 
get all of the photos on the card, even if only some are selected.
In either case, iPhoto swings into action, copying photos from your camera to 
your hard drive. You get to see them as they parade by. When it’s done and the 
photos are safe on your computer, iPhoto has another question for you: Do you 
want to delete the transferred pictures from the memory card?
If you click Delete Photos, iPhoto deletes the transferred photos from the mem-
ory card (either all of the photos or just the selected ones, depending on the 
button you clicked at the beginning of this step). The memory card will then 
have that much more free space for another exciting photo safari.
If you click Keep Originals, then iPhoto leaves the memory card untouched. 
(You can always use the camera’s own menus to erase its memory card.)

4.	 “Eject”	the	camera	by	clicking	the	E button	next	to	its	name	in	the	Source	list	
(on	the	left	side	of	the	iPhoto	screen).
Or, if the E button doesn’t appear, just drag the camera’s icon directly onto the 
Trash icon in the Source list. You’re not actually throwing the camera away, of 
course, or even the photos on it—you’re just saying, “Eject this.” Even if the cam-
era’s still attached to your Mac, its icon disappears from the Source list.
At last, your freshly imported photos appear in the main iPhoto window, await-
ing your organizational talents.

5.	 Turn	off	the	camera,	and	then	unplug	it	from	the	USB	cable.

You’re ready to start having fun with your new pictures.

Note: You can also drag photos (or folders of them) directly from your desktop into iPhoto. Or you can 
insert your camera’s memory card into a card reader. Or you can click the “Add to iPhoto” button wher-
ever it appears in Mac OS X, like in Mail or during a Finder slideshow.
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The File Format Factor
iPhoto can’t import digital pictures unless it understands their file format, but that 
rarely poses a problem. Every digital camera on earth can save its photos as JPEG 
files—and iPhoto handles this format beautifully. (JPEG is the world’s most popular 
file format for photos, because even though it’s compressed to occupy a lot less disk 
space, the visual quality is still very high.)

But iPhoto ’11 imports and recognizes some other very useful formats.

Raw format
Most digital cameras work like this: When you squeeze the shutter button, the cam-
era studies the data picked up by its sensors. The circuitry then makes decisions 
pertaining to sharpening level, contrast and saturation settings, color “temperature,” 
white balance, and so on—and then saves the resulting processed image as a com-
pressed JPEG file on your memory card.

For millions of people, the resulting picture quality is just fine, even terrific. But all 
that in-camera processing drives professional shutterbugs nuts. They’d much rather 
preserve every last iota of original picture information, no matter how huge the re-
sulting file on the memory card—and then process the file by hand once it’s been 
safely transferred to their Mac, using a program like Photoshop.

That’s the idea behind the Raw file format, which is an option in many pricier digital 
cameras. (Raw stands for nothing in particular, so there’s no good explanation for 
why it’s so often written in all capitals.)

A Raw image isn’t processed at all; it’s a complete record of all the data passed along 
by the camera’s sensors. As a result, each Raw photo takes up much more space on 
your memory card. For example, on a 6-megapixel camera, a JPEG photo is around 
2 MB, but over 8 MB when saved as a Raw file. Most cameras take longer to store 
Raw photos on the card, too.

But for image-manipulation nerds, the beauty of Raw files is that once you open 
them up on your Mac, you can perform astounding acts of editing on them. You can 
actually change the lighting of the scene—retroactively! And you don’t lose a single 
speck of image quality along the way.

Until recently, most people used programs like Photoshop or Photoshop Elements 
to do this kind of editing. But amazingly enough, humble, cheap little iPhoto ’11 can 
now edit Raw files, too.
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Movies
In addition to still photos, today’s digital cameras can also capture digital movies. 
These are no longer the jittery, silent affairs the size of a Wheat Thin; modern cam-
eras capture full-blown, 30-frames-per-second, fill-your-screen movies—even high-
definition movies! 

Movies eat up a memory card plenty fast, but you can’t beat the convenience, and the 
quality comes breathtakingly close to camcorder quality. (Recent camera models can 
even zoom and change focus while “filming,” just like a camcorder.)

Fortunately, iPhoto can import and organize them. The program recognizes .mov 
files, .avi files, and many other movie formats. In fact, it can import any format that 
QuickTime (the program on your Mac that actually plays these movies) recognizes, 
which is a very long list indeed.

You don’t have to do anything special to import movies; they get slurped in auto-
matically. To play one of these movies once it’s in iPhoto, double-click it; it opens up 
in QuickTime Player.

Other graphics formats
Of course, iPhoto also lets you load pictures that have been saved in a number of 
other file formats: TIFF, GIF, PNG, BMP, PICT, Photoshop, and so on.

The Post-Import Inspection
Once you’ve imported a batch of pictures into iPhoto, what’s the first thing you want 
to do? If you’re like most people, this is the first opportunity you have to see, at 
full-screen size, the masterpieces you and your camera created. After all, until this 
moment, the only sight you’ve had of your photos is on the little screen on the back 
of the camera. 

There’s a great way to go about inspecting your pictures after you’ve completed them: 
the old “double-click to magnify” trick.

Once you’ve imported some pictures, click the Last Import icon in the Source list. In 
the main iPhoto window, you’re now treated to a soon-to-be-familiar display: a grid 
of thumbnails. In this case, they represent the pictures you just imported. Double-
click the first one. If all goes well, it now swells to fill the main part of the iPhoto 
window.
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After the shock of seeing the giant-sized version of your photo has worn off, press the 
˘ key to bring the second one into view. Press it again to continue walking through 
your imported photos, checking them out.

This is the perfect opportunity to throw away lousy shots, fix the rotation, and 
linger on certain photos for more study. You can even apply a rating by clicking 
the appropriate star in the band of five; later, you can use these ratings to sort your 
pictures or create smart albums (page 96 of this appendix). Here’s the full list of 
things you can do as you walk through the magnified pictures:

• Double-click the photo to de-magnify it. You return to the window full of 
thumbnails. (Double-click another one to magnify it and return to the inspec-
tion process.)

• Press the ¯ and ˘ keys on your keyboard to browse back and forth through your 
photos, or use the new filmstrip at the bottom of the iPhoto window.

• Press the Delete key on your keyboard to send a photo to iPhoto’s Trash can.
• Give each photo a rating in stars, from 1 (terrible) to 5 (terrific). To do that, 

press c-1 through c-5 (or press c-0 to remove the rating). 

Tip: You won’t actually see the stars appear unless you open the Info panel by clicking the little Info but-
ton at the bottom right of the iPhoto window.
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Control-clicking a photo displays a shortcut menu that gives you access to more 
goodies:

• Click the Rotate button to flip a photo counterclockwise, 90 degrees at a time. 
(Option-click it to rotate the photo clockwise instead.)

• Click the Hide button to hide a photo, which isn’t the same thing as deleting it. 
The photo is out of your way, but it’s still in your library, and you can always 
bring it back. You can accomplish the same thing (without Control-clicking 
first) by pressing c-L. Either way, the now-hidden photo disappears from the 
filmstrip at the bottom of your iPhoto window, but it stays onscreen (sigh). 

• Click the Trash button to throw your photo into iPhoto’s very own Trash can 
(see page 97 of this appendix).

• Edit the image in iPhoto by choosing “Edit in iPhoto,” or open it in anther 
program (say, Photoshop Elements) by choosing “Edit in External Editor.”

• If you Control-clicked a photo while viewing an Event, you can make this photo 
the key photo (the icon thumbnail) for the Event by choosing Make Key Photo. 
You’ll learn about key photos on page 81 of this appendix.

When you’re finished walking through your pictures, double-click anywhere on the 
photo to return to your thumbnails.

Organizing Your Photos
When you get right down to it, working in iPhoto takes place at three different zoom 
levels. You begin fully zoomed out, looking at piles of photos—your Events (called 
Spring Break, Robin’s Graduation, and so on). Then you drill down into one of the 
piles; in the main Photos view, every picture appears as an individual thumbnail. 
Finally, you can zoom in even more, filling the screen with just one photo.

If you’ve imported photos into iPhoto, as described in the previous section, your 
journey out of chaos has begun. You’re not really organized yet, but at least all your 
photos are in one place. From here, you can sort your photos, give them titles, group 
them into smaller sub-collections (called albums), and tag them with keywords so 
you can find them quickly.

Even before you start naming your photos, assigning them keywords, or organizing 
them into albums, iPhoto imposes an order of its own on your digital shoebox. The 
key to understanding it is the Source list at the left side of the iPhoto window. This 
list grows as you import more pictures and organize them—but right off the bat, 
you’ll find categories like Library, Recent, and Albums, each containing icons you 
can click for fast access to particular photos (Last Import, Last 12 Months, and so 
on).
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The first two icons in the Source list, under a heading called Library, are the most 
important. No matter how confused you may get in working with subsets of photos 
later in your iPhoto life, clicking one of these icons (Events or Photos) returns you to 
your entire picture collection. It makes all of your photos appear in the viewing area.

Events View
The primary photo-organizing concept in iPhoto ’11 is the Event: a group of photos 
that were all taken at about the same time. It certainly makes a lot more sense than 
the film roll, the organizing construct of earlier versions of the program. (A film roll 
was all the photos you imported at once, no matter how many months apart you 
took them).

Note: If you upgrade to iPhoto ’11 from an earlier version, your old film rolls are automatically converted 
into Events.

iPhoto does this auto-splitting automatically whenever you bring new pictures in, if 
you’ve told it to do so by turning on the Split Events checkbox shown back on page 
73 of this appendix. If you don’t, then all the pictures you import in a single batch get 
clumped into a single Event, regardless of when they were taken. If you’re importing 
photos from your hard drive, they get dumped into a single Event, too.

Defining an Event
Right out of the box, iPhoto defines an Event as one day. So if you took pictures on 
June 1, 2, and 3, you’ll wind up with three Events.

You might consider that breakdown too granular, though. It’s not an especially logi-
cal grouping if, for example, you were away for a wedding weekend, a three-day trip 
to a theme park, or a week-long cruise. In all of those cases, you’d probably consider 
all the photos from that trip to be one Event.

In other, less common situations, you might consider one day to be too long a win-
dow. If you’re a school photographer who conducts two shooting sessions a day—
morning and afternoon, for example—you might want iPhoto to split up the incom-
ing photos into even smaller time chunks, like a new Event every four hours.

In any case, iPhoto can accommodate you. Choose iPhoto→Preferences and then 
click the General button. From the “Autosplit into Events” pop-up menu, take your 
pick: “One event per day,” “One event per week,” “Two-hour gaps,” or “Eight-hour 
gaps.” (Those “gap” options are iPhoto’s way of saying, “If more than that many hours 
have elapsed since the last batch you took, then I’ll call it a new Event.”)

Of course, it’s extremely easy to split, merge, slice, and dice Events, move photos 
around between Events, and so on, as you’ll learn later in this appendix. But you may 
as well let iPhoto do the bulk of the grunt work the moment you import the pictures.
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The Events List
When you click Events at the top of the Source list, you see an array of big, rounded 
thumbnails, as shown below:

These thumbnails represent your Events. To save space, iPhoto shows only one pic-
ture from each Event; you can think of it as the top photo on a pile. Using that sample 
photo, along with the Event’s name and date, you should be able to figure out which 
pile of photos each Event contains.

Here’s what you can do when you’re looking at the Events thumbnails:

• Scan	through	a	pile. Here’s a tricky move that’s relatively new to the Macintosh 
skill set: Move your cursor sideways across an Event thumbnail without clicking. 
As you go, the photo on the face of the thumbnail changes, as all the pictures 
within flicker by. It’s a good, quick way to get a look at the other pictures in the 
virtual heap.

• Sort	 the	 Events. Ordinarily, iPhoto presents the Event thumbnails in chron-
ological order; in effect, it chooses View→Sort Events→By Date for you. But 
you can also sort them alphabetically by choosing View→Sort Events→By 
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Title. In either case, you can also reverse the sorting by choosing View→Sort 
Events→Descending (or Ascending).

• Rearrange	 the	 Event	 thumbnails. You can drag one thumbnail between two 
others to rearrange them. When you do that, iPhoto chooses View→Sort 
Events→Manually for you, because your thumbnails are no longer sorted alpha-
betically or chronologically.

• Change	the	key	photo. The key photo is the one on top of the pile, the one that 
represents the Event itself. As it turns out, iPhoto suggests one, but only at ran-
dom. Usually, you’ll want to rummage through the pictures and choose a better 
one to represent the whole batch. For a birthday party, for example, you might 
choose the candle-blowing-out shot to be the one on top of the pile.
To change the key photo, scan through the pile using the cursor as described 
above. When you see the picture you want to be the new key photo, tap the 
space bar; or, Control-click (or right-click) the thumbnail and then, from the 
shortcut menu, choose Make Key Photo.

• Rename	an	Event. To rename an Event, just click its existing name and then 
type away. Press Enter, or click somewhere else, when you’re finished.

• Merge	 Events. You can combine two (or more) Events into one by dragging 
one Event’s thumbnail onto another. iPhoto instantly combines the two sets of 
photos. (The one you dragged vanishes; the combined pile assumes the name 
and key photo of the one you dragged onto.)

• Delete	an	Event. If you’re quite sure you want to ditch an entire batch of pic-
tures, click its thumbnail and then press c-Delete. (Or drag the Event’s thumb-
nail onto the Trash icon in the Source list.) Later, you can empty iPhoto’s Trash.

Double-clicking an Event thumbnail opens up the Photos view, where the main part 
of the iPhoto window is filled with the individual thumbnail of all the pictures in 
that Event, as shown in the figure above (bottom image). From here, you can search, 
sort, edit, and otherwise work with your photos as described in the rest of this ap-
pendix.

You can always return to the Events screen by clicking Events in the Source list or 
clicking the All Events arrow button at the top left of the iPhoto window.

Photos View
When you click Photos in the Source list, or when you double-click an Event, you 
arrive at the main iPhoto display. It’s called, for want of a better term, Photos view.

This is your lightbox, your slide sorter. Here, every photo has its own thumbnail. 
You can scroll through this list, looking over your pictures or flagging them with 
keywords, ratings, and descriptions. Here’s where you choose photos for inclusion in 
slideshows, prints, books, and calendars.

You can make the thumbnails in iPhoto grow or shrink using the Zoom slider in the 
iPhoto toolbar, just under the photo-viewing area.
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Sorting Photos
Using the View→Sort Photos submenu, you can make iPhoto sort all the thumbnails 
in the main window in a number of useful ways:

• By	date. This sort order reflects the dates the photos were taken.
• By	 keyword. This option sorts your photos alphabetically by the keywords 

you’ve assigned to them.
• By	title. This arrangement is alphabetical by the photos’ names.
• By	rating. If you’d like your masterpieces at the top of the window, with the los-

ers way down below, choose this option.
• Manually. If you choose this option, you can drag the thumbnails around freely 

within the window, placing them in any order that suits your fancy. To conserve 
your Advil supply, however, make no attempt to choose this item when you’re 
viewing one of the Events’ contents—do so only in an album.

Creating Events Manually
Events are such a convenient way of organizing your pictures that Apple even lets 
you create Events manually, out of any pictures you choose.

You just select any bunch of pictures in your Library, then choose Events→Create 
Event. iPhoto creates and highlights the new Event, like any normal Event. It then 
gives the newborn Event the generic name “untitled event.” You can always rename 
it. 

Splitting Events
Here’s yet another way to create a new Event: split off a bunch of photos from another 
one. You can either ask iPhoto to do that automatically, based on when the pictures 
were taken, or you can do it manually.

• The	automatic	way.	Suppose you didn’t turn on the “Autosplit into events check-
box” when you imported some photos, and now you’re having second thoughts. 
You wound up importing hundreds of pictures taken over the course of several 
weeks, and now you decide that it would be sort of handy if they were broken 
up by day or by week.
Click Events in the Source list, and then highlight the Event or Events that you 
want to split. Finally, choose Events→Autosplit Selected Events. iPhoto auto-
matically breaks up the selected Events into more Events, as necessary, to put 
photos into the desired groupings (to determine what constitutes an Event, see 
“Defining an Event” on page 79 of this appendix).

• The	 manual	 way. You can also chop an Event in two, subdividing it at any 
point that feels right. For example, iPhoto may have grouped 24 hours’ worth 
of photos into a single Event, even though you actually got 5 hours’ sleep in the 
middle and would prefer the subsequent photos to appear in their own Event.
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To split an existing Event in two, click Events in the Source list, and then open 
the Event you want to split. Scan through the thumbnails and then click the 
photo that marks the beginning of what you’d like to become the new, separate 
Event. Finally, choose Events→Split Event, or press the S key on your keyboard. 
iPhoto creates a second Event out of the photo you clicked and all the ones 
after it, and names it “untitled event”(just click the Event’s name and type to  
rename it). 

Moving Photos Between Events
The fact that iPhoto offers to group photos into Events by time period is a handy 
starting point. But it’s only a starting point. You can, and should, freely drag photos 
among your Events according to any logic that suits you.

In Photos view, select the photo(s) you want to move. Then just drag them directly 
onto another Event’s name. The deed is done.

Hiding Photos
For years, you had only two choices when confronting a so-so photo in iPhoto: Keep 
it or delete it. But now you have another option: you can hide a photo. It’s there be-
hind the scenes, and you can always bring it back into view should the need arise. 
In the meantime, you can pare your visible collection down to the really good shots, 
without being burdened every day by the ghosts of your less impressive work.

To hide some photos, select them, and then press c-L, or choose Photos→Hide 
Photos. The selected photos vanish. Of course, they’re still taking up disk space. But 
they no longer bog down iPhoto when you’re scrolling, and they no longer depress 
you when they stare out at you every day.

But don’t worry, iPhoto doesn’t let you forget that they’re there. Whenever you open 
an Event, the words “(7 more hidden)”—or whatever the number is—appear in the 
title bar.

To bring all your hidden photos back into view for a moment, choose View→Hidden 
Photos. They all reappear, bearing big red Xes on their corners. This is your chance 
to reconsider—either to delete them for good, or to welcome then back into the 
non-hidden society. Of course, you can re-hide the hidden photos whenever it’s con-
venient, just by choosing View→Hidden Photos again.

Now, just marking a photo as hidden doesn’t mean you can’t change your mind. At 
any time, you can un-hide it, turning it back into a full-fledged photographic citizen. 
To do that, first make your hidden photos visible, as described above. Then select 
the photo(s) you want to un-hide, and repeat whatever step you took to hide it in the 
first place. For example, press c-L, or choose Photos→Unhide Photos.
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Faces and Places
iPhoto gives you plenty of ways to organize your pictures into neat little collections. 
But until the ’09 version came along, the only way to organize everything was manu-
ally. Manually apply keywords. Manually drag things into albums. Drag, drag, drag. 

Now it’s all different. iPhoto comes with two features that organize your photos au-
tomatically. The Faces tool helps you keep track of who is in your photos. The Places 
tool helps you keep track where you took your shots. This section shows you the 
ropes.

Faces
Here’s the Faces feature in a nutshell: By analyzing the unique properties of each face 
in each photo—distance between the eyes, nose, mouth, hair color, lack of hair, and 
so on—iPhoto attempts to distinguish among the people in your photos and group 
them into piles. (Once the setup process is complete, you’ll see these piles when you 
click the Faces icon in your Source list.) 

But even after iPhoto groups similar faces together (this process happens automati-
cally), it still needs your help learning everybody’s name. iPhoto can group all your 
shots of your uncle Robin Hall together—but it still needs you to tell it that the 
round-faced guy with the big cheekbones is called Robin Hall. Here’s what you need 
to do to put names to faces: 

1.	 Click	Faces	in	your	Source	list.
iPhoto displays thumbnails of a few faces it finds in your library. The first time 
you go to Faces, the screen will look like the image below.

2.	 Click	 the	“unnamed”	 label	below	a	 thumbnail	and	 type	 the	person’s	name,	
and	then	press	Return.
While you can type any name you want—like Dad or Uncle Robin—it’s a good 
idea to stick with the person’s real name, as iPhoto automatically tries to match 
it with the contents of your Address Book.
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When you’ve had your fill of naming faces, click Continue To Faces at the bottom 
right of the iPhoto window. As shown below, you now see a corkboard with Pola-
roid-style shots of each person you’ve tagged so far, labeled with the names you just 
assigned. It’s like being the casting director in the movie of your life.
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Tagging Faces Manually

If iPhoto fails to detect a face during import or rescan—a fairly rare occurrence—
you can always tag it yourself. Start by selecting the photo and then opening the Info 
panel. In the panel, click the word Faces to expand that section and then click “Add 
a face,” as shown below.

A fresh white square appears, which you can drag over that poor, undetected face. 
Drag the corners of the box to resize it. (Dragging a corner causes both sides of the 
box to change size, making it a little awkward to get perfectly centered over the face. 
To better control your box resizing, hold down the Option key as you drag a corner. 
This stops both sides of the box from moving around and lets you manipulate the 
size from just the corner you’re dragging.)
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When you’ve got the white square right where you want it, click the “click to name” 
balloon and type the person’s name. Repeat as necessary with any other people you 
know in the picture.

Adding More Pictures to a Name

Once you’ve put at least one name to a face, iPhoto’s powers of recognition really 
kick in. Here’s how to help it match up the rest of the names and faces:

1.	 Double-click	a	person	on	the	Faces	corkboard.
iPhoto displays all the photos you’ve already tagged with this person’s name. At 
the bottom of the window, you see a note telling you how many other pictures 
iPhoto thinks contain this same person.

2.	 Just	above	the	iPhoto	toolbar,	click	Confirm	Additional	Faces.
The program now displays a screen full of tiles. Each tile contains a close-up of 
the lucky person’s face, each culled from a different photo. The caption “click to 
confirm” appears beneath each one. 

3.	 Click	a	photo	once	to	confirm	that	iPhoto	has	correctly	matched	this	face	with	
the	name.
When you click a face, the “click to confirm” bar turns green and displays the 
name of the person—for example, Chris. Behind the scenes, iPhoto learns from 
your selection. “Ah, OK—that’s Chris,” it says to itself. You’ve just helped it re-
fine its recognition smarts for next time.

4.	 When	you	encounter	a	tile	that	shows	somebody	else—iPhoto	has	picked	the	
wrong	person—either	Option-click	it	or	double-click	it.
The “click to confirm” banner turns red, and the text says, “Not Chris” (or who-
ever).

Tip: Here again, you can reject a whole bunch of tiles at once. This time, hold down the Option key as 
you drag the cursor over the faces.

5.	 When	you’re	finished	accepting	or	rejecting	tiles,	click	Done.

The more guidance you give iPhoto in identifying people in your photos, the more 
accurate it gets at recognizing them in new images. With enough input from you, 
the program has a better chance of telling babies and bald men apart, and even dif-
ferentiating among your various bald friends.
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Places
Geotagging is the latest hot feature of digital photography. That’s when your camera 
buries longitude and latitude coordinates into each picture it takes (invisibly, the 
same way it stamps the time and date) so you’ll always be able to pinpoint where a 
picture was taken. There are only two problems with this scenario.

First, very few cameras actually contain the necessary GPS circuitry to geotag your 
photos. Second, what happens after you geotag your photos? What are you going to 
do, say, “Oh, yes, I remember that romantic evening at +41º 30' 18.48" N, -81º 41' 
55.08" W”? iPhoto solves the second problem, at least. It translates those coordinates 
to the much more recognizable “Cleveland,” or even more precisely, a street address, 
like “100 Alfred Lerner Way, Cleveland, Ohio” (which happens to be the address of 
Cleveland Browns Stadium)—and shows that spot with a red pin on a map right in 
iPhoto. This can be really convenient if you’ve made several trips to London and 
want to see all the pictures taken there over the years, and not just ones from a par-
ticular album or Event. 

Note: These days, privacy concerns run deep. If you don’t want iPhoto to look up the GPS data in your 
photos, choose iPhoto→Preferences and then click the Advanced icon. In the “Look up Places” pop-up 
menu, change Automatically to Never, and then click OK.

Automatically Geotagging Photos

Your photos are probably geotagged when you shoot them if you’re using one of the 
following gadgets:

• A digital camera with a built-in GPS chip, like the Nikon Coolpix P6000.
• A GPS-enabled cellphone, like a recent iPhone.
• The Eye-Fi Geo Card. It’s a remarkable SD memory card, the kind you put into 

most camera models, with built-in wireless networking and a pseudo-GPS fea-
ture ($70 for a 4 GB card). See www.eye.fi for details.

• A small GPS-enabled box like the $90 ATP PhotoFinder that tracks the time 
and your coordinates as you snap photos—and marries them up with the time 
stamps on your pictures when you insert the camera’s memory card. See http://
photofinder.atpinc.com for more information.

If that’s your situation, then all you have to do is import the pictures into iPhoto 
(page 72 of this appendix) and smile smugly. When the images appear in the viewing 
window, you can check the location by clicking the Info button on the iPhoto toolbar 
to open the Info panel shown below. If iPhoto gets the location wrong, check the 
next section to learn how to manually geotag photos.
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Manually Geotagging Photos

But what about photos that don’t have geographical information embedded—like 
the 300 billion photos that have been taken with non-GPS cameras? Here is what 
to do:

1.	 Select	a	photo	or	an	Event	and	then	click	the	Info	button	on	the	iPhoto	tool-
bar.
The Info panel opens to reveal several bits of information, including the name 
of the picture.
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2.	 Click	“Assign	a	Place”	and	start	typing	the	name	of	the	town,	city,	or	landmark	
(like	Washington Monument)	where	the	picture	was	taken.
As shown below, a pop-up menu appears; iPhoto is trying to guess what you’re 
typing, to save you some effort (and spelling). If you see the location in the list, 
use the arrow keys on your keyboard to select it and then press Return to con-
firm your choice, or just click the correct location in the list.

3.	 If	the	place	you’re	typing	doesn’t	appear	on	the	list,	pick	one	that’s	close	and	
then	move	the	marker	pin.
Unlike the previous version of the program, iPhoto ’11 doesn’t have a “Find on 
Map” option, mainly because you don’t need it. In the off chance that iPhoto and 
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Google can’t find your location, just pick a spot that’s close. Then, click the red 
pin on the little map and drag it to the correct location, as shown in the figure 
below.

4.	 When	the	pin	is	in	the	right	spot,	click	the	checkmark	next	to	the	location	tag	
to	confirm	it.
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Looking at Your Place Photos

Now that your photos are geotagged, detailed, and ready, it’s time to see how they 
look in iPhoto’s Places view. In the Source list, click Places. Or, if the Info panel is 
open, click ‰ in your photo’s location tag (labeled above).

In the Places map view shown below, a global map fills your screen, festooned with 
little red pins representing all the pictures you’ve geotagged. To see the photos at-
tached to a pin, point to that pin and click the O next to the place’s name.

Here are some ways to navigate the map:

• Zoom	in by double-clicking a pin until you get as close as you want.
• Zoom	out of the map by Control-clicking (or right-clicking) twice.
• Zoom	in	or	out by dragging the slider near the bottom-left of the iPhoto tool-

bar.
• To	travel	more	incrementally, drag the map itself with the mouse to get to the 

part you want to see.
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• See	all	your	pins	on	the	map	at	once by clicking the Home button at the top left 
of the iPhoto window (it looks like a little house).

• See	 all	 the	 countries,	 states,	 cities,	 and	 places	 you’ve	 visited by clicking the 
floating lists at the top of the map. These lists are new in iPhoto ’11; they let you 
view photos by region.

Play around with Faces and Places. The features are really handy for super-popular 
globetrotters like you.

Three Ways to Open a Photo
iPhoto wouldn’t be a terribly useful program if it let you view only postage-stamp 
versions of your photos. Fortunately, iPhoto offers three ways to view your pictures 
at something much closer to actual size.

You’ll use these methods frequently when you start editing your photos. For the 
moment, though, it’s useful to know about these techniques simply for the more 
common act of viewing the pictures at larger sizes.

Method 1: Right in the Window
The easiest way to open a photo is simply to double-click its thumbnail. Unless 
you’ve changed iPhoto’s settings, the photo opens in the main iPhoto window, scaled 
to fit into the viewing area.

Method 2: Full Screen View
Here’s another way to take a gander at a photo: Full Screen view. (You could get this 
view in previous versions, but it involved tweaking iPhoto’s preferences.) Just click 
the Full Screen button in the bottom left of the iPhoto window and the selected 
photo fills your entire monitor, edge to edge (below). There’s no Source list stacked 
with icons down the left side—everything you need shrinks down to the smallest 
possible size at the top and bottom of your screen, letting you focus on your glorious 
photo, blown up as big as it can go. To exit Full Screen mode, click Full Screen again. 

Tip: Full Screen view is particularly helpful when you’re touching up photos (page 98 of this appendix). 
The blown-up view helps you make precise edits and changes. Once you’re in Full Screen mode, click Edit 
(in the bottom right of your monitor) to fix your shots.
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Method 3: In Another Program
Apple knows there’s other software out there—big, burly photo-editing programs 
like Adobe Photoshop or Apple’s Aperture. That’s why you can tell iPhoto that you’d 
rather use a different program for manipulating the finer points of your photos. To 
do so, choose iPhoto→Preferences→Advanced→Edit Photos→“In application” and 
then pick another program installed on your Mac.

Albums
An album is a collection of your pictures—drawn from a single Event or many dif-
ferent ones—that you group together for easy access and viewing. Represented by a 
little album-book icon in the Source list at the left side of the screen, an album can 
consist of any photos that you select.
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While your iPhoto Library as a whole might contain thousands of photos from a 
hodgepodge of unrelated family events, trips, and time periods, a photo album has a 
focus: Steve & Sarah’s Wedding, Herb’s Knee Surgery, and so on.

Creating an Empty Album
To create a new, empty photo album, press c-N. (Choosing File→New Album grabs 
some—or all—of your photos, depending on what’s active in your Source list, so the 
new album isn’t empty.) Now you can add photos to your newly spawned album by 
dragging in thumbnails from your Library, as shown here:

There’s no limit to the number of albums you can add, so make as many as you need 
to satisfactorily organize all the photos in your Library.
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Merging Albums
Suppose you have three albums that contain photos from different trips to the beach, 
called Spring Break at Beach, Summer Beach Party, and October Coast Trip. You’d 
like to merge them into a single album called Beach Trips 2010. No problem.

Select all three albums in the Source list (c-click each, for example); the photos 
from each now appear in the photo-viewing area. Now create a new, fourth album 
by pressing c-N. Finally, select all of the visible thumbnails by pressing c-A, and 
then drag them into the new album.

You now have one big album containing the photos from all three of the original al-
bums. You can delete the three source albums, if you like, or keep all four around. Al-
bums contain only references to your photos—not the photos themselves—so you’re 
not wasting space by keeping the extra albums around. The only penalty you pay is 
that you have a longer list of albums to scroll through.

Deleting an Album
To delete an album, select its icon in the Source list, and then press the Delete key. 
You can also Control-click (right-click) an album and choose Delete Album from 
the shortcut menu. iPhoto asks you to confirm your intention.

Deleting an album doesn’t delete any photos—just the references to those photos. So 
even if you delete all your photo albums, your Library remains intact.

Smart Albums
iPhoto can also fill up albums for you, thanks to smart albums. These are self- 
updating folders that always display pictures according to certain criteria that you 
set up—all pictures with “Aunt Edna” in the comments, for example, or all photos 
that you’ve rated four stars or higher. (If you’ve ever used smart playlists in iTunes, 
you’ll recognize the idea immediately.)

To create a smart album, choose File→New Smart Album (Option-c-N), or Op-
tion-click the + button below the Source list. Either way, the Smart Album sheet 
slides down from the top of the window.
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Click the + button to add a new criterion row to be even more specific about which 
photos you want iPhoto to include in the smart album. Use the first pop-up menu to 
choose a type of photo feature (keyword or date, for example) and the second pop-
up menu to tell iPhoto whether you want to match it (“is”), eliminate it (“is not”), 
and so on. The third part of the criterion row is another pop-up menu or a search 
field where you finally tell iPhoto what to look for.

When you click OK, your smart album is ready to show off. When you click its name 
in the Source list (it has a little F icon), the main window displays the thumbnails 
of the photos that match your criteria. The best part is that iPhoto keeps this album 
updated whenever your collection changes—as you change your ratings, take new 
photos, and so on.

Deleting Photos
As every photographer knows—well, every good photographer—not every photo is a 
keeper. So at some point, you’ll probably want to delete some of your photos.

The iPhoto Trash
iPhoto has a private Trash can that works just like the Finder’s Trash. It’s sitting there 
in the Source list (under the Recent heading, for some reason). When you delete a 
picture, iPhoto puts it into the Trash “folder,” awaiting permanent disposal via the 
Empty Trash command. This feature gives you a layer of protection against acciden-
tally deleting a precious picture.

In the main Photos view, you can relegate items to the Trash by selecting one or more 
thumbnails in your Library (not in an album, but in Events or Photos view) and then 
pressing the Delete key.

To permanently delete what’s in the Trash, choose iPhoto→Empty iPhoto Trash. 
iPhoto then displays an alert message, warning you that emptying the Trash removes 
these photos permanently and irreversibly. Only when you click OK does the iPhoto 



98 ilife crash course

iPhoto ’11

Library folder actually shrink in size. Whatever pictures you throw out by emptying 
the Trash also disappear from any albums you’ve created.

Editing
When you click a photo’s thumbnail and then click Edit (on the bottom toolbar), the 
photo opens in the main iPhoto window, scaled to fit into the viewing area. Better 
yet, open the photo in Full Screen mode as described on page 93 of this appendix. 
(Full-screen editing gives you a much larger view of the photo you’re working on.)

Opening a photo in Edit view also summons these editing tools:

• Rotate. Click the Rotate button to flip a photo, 90 degrees at a time.
• Enhance. With one click, this tool tries to make photos look more vibrant by au-

tomatically tweaking their brightness and contrast settings and adjusting their 
saturation to compensate for washed-out or oversaturated colors.

• Fix	Red-Eye. This button gets rid of a very common photo glitch—those shin-
ing red dots that sometimes appear in a person’s eyes as the result of flash pho-
tography. Who wants to look like a werewolf?

• Straighten. If the camera wasn’t quite straight when you took the picture, click 
this button, then drag the slider that appears. iPhoto automatically tilts the pho-
to to compensate, enlarging it in the process to fill in the gaps at the corners.

• Crop. The cropping tool lets you cut away the outer portions of a photo to im-
prove its composition or to make it the right size for a printout or web page. 
Click the Crop button, and then choose a fixed proportion from the Constrain 
menu, if you like. Next, drag across the photo to indicate how you want it 
cropped. Finally, click Done or press Return. (You can always restore the photo 
later.)

• Retouch. This little brush lets you paint out minor imperfections like blemishes, 
freckles, and scratches.

Two tabs at the top right of the Editing window give you even more editing controls: 

• Effects. Opens a panel of special-effects buttons like black-and-white, sepia, 
and so on.

• Adjust. This panel’s sliders offer ridiculous amounts of control over color bal-
ance, exposure, and other aspects of your photos.
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Sharing Your Pix
The payoff for all of this organizational and editing effort is, of course, showing your 
photos to other people. iPhoto is endlessly talented in this department. After you 
select some photos or an album, here’s what you can do.

Print
iPhoto can print out your photos on standard sizes of inkjet photo paper, or you can 
use a template that clusters several photos onto each sheet, saving paper and ink. 
Choose File→Print and iPhoto opens a screen that helps you print your photos.

If you’d rather order prints from Kodak (for a fee), select some photos and then 
choose File→Order Prints to get started. 

Slideshow
Onscreen slideshows are easy to set up, they’re free, and they make your photos 
look fantastic. Your Mac presents the pictures in full-screen mode—no windows, no 
menus, no borders—with your images filling every inch of the monitor. Each picture 
fades gently into the next, producing a smooth, cinematic effect. If you want, you can 
even add a musical soundtrack to accompany the presentation. The easiest way to 
get started is by clicking the Slideshow button in the middle of the iPhoto toolbar. In 
the Themes panel that appears, click a theme to select it, and then click Play. 

Email
Full-size photos are usually too big to email. They take forever to download, they run 
the risk of exceeding your recipient’s Inbox limit, and they open up much too large 
on your victims’ screens. Fortunately, iPhoto can automatically send a scaled-down, 
reasonably sized version of your photos instead, complete with captions, frames, and 
other graphic niceties. iPhoto even does the emailing itself, without having to open 
your email program.

Here’s how the new embedded-email process works:

1.	 Select	the	thumbnails	of	the	photo(s)	you	want	to	email.
You can choose up to 10 photos for a single email. 

2.	 Click	 the	Share	 icon	 in	 the	 iPhoto	 toolbar;	 from	the	pop-up	menu,	choose	
Email	(below).
If you’ve never used Mail (Apple’s email program) you’ll see the pane below.
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3.	 Choose	a	theme.
Apple believes emailing your photos is an event worthy of graphics, descrip-
tions, captions, and so on. You can choose among 10 designs themes in the 
Themes pane, shown below.

4.	 Size	and	position	your	photos	within	their	frames.
As with any project—a book, calendar, card (keep reading for details)—you can 
resize and reposition your photos inside each frame,

5.	 Choose	to	attach	photo(s)	or	not,	and	if	so,	choose	the	attachment	size.
Once you’re happy with your design and click Send, iPhoto converts the com-
pleted layout into a single JPEG image in the body of the message. But if “Attach 
photos to message” is turned on, iPhoto also compresses the photos into a single 
.zip file (which your recipient can double-click to open) and attaches it to the 
message.
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Note: iPhoto encourages you to send scaled-down versions of your photos, so it automatically sets the 
Photo Size to Optimized, which works just fine in most cases—big enough for onscreen display, just not for 
printing.

6.	 Include	a	personal	message,	caption,	or	title,	if	desired.
On the left side of the window is the actual email you’ll send, and the body area 
is filled with text boxes you can customize; just click to change the text and use 
the little pop-up menus to change the typeface, size, and so on. 

7.	 Type	your	recipient’s	email	address	into	the	“To:”	box,	and	then	click	Send.

Your photos are then sent on their merry way.

Books, Calendars and Cards
What the heck do you get your dad after you’ve already given him birthday and 
holiday presents for 15 or 35 years? If you have iPhoto, you’ve got an ironclad, pe-
rennial answer. The program’s Book feature lets you design and order (via the Inter-
net) a gorgeous, professionally-bound book. These books ($30 and up) are amazing 
keepsakes to leave out on your coffee table—the same idea as most families’ photo 
albums, but infinitely classier and longer lasting (and not much more expensive).

Since iPhoto’s debut, in fact, the self-publishing business has expanded. You can now 
create equally great-looking calendars (covering any year, or any group of months 
that works for you), postcards, and new in iPhoto ’11, letterpress greeting cards 
(cards that have inked designs pressed into the paper). Your projects arrive beauti-
fully wrapped in elegant, Apple-logoed envelopes that are a sight to behold in and 
of themselves. 

This section gives a detailed description of how to make a book, then briefly explains 
how to make calendars and cards (the processes are very similar). 

Creating a Book

To make a book in iPhoto, selected an album or a batch of photos and then choose 
File→New→Book. Now you see something like this:
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This screen lets you choose between hardcover, softcover, or wire-bound; pick a 
color scheme (from the options on the bottom right); and select a book size (from 
the bottom left). Your biggest choice here is your book’s theme; the different options 
are presented in the center of the screen. Click on any theme option and iPhoto 
scrolls it to the front so you can take a look (you can also use the arrow keys on your 
keyboard to scroll through the themes). At the bottom of the screen, iPhoto shows 
you a preview of the inside pages. When you find a theme you like, click Create.

At this point, two things happen. First, a new icon appears in your Source list, rep-
resenting the book layout you’re about to create. You can work with it as you would 
other kinds of Source-list icons. For example, you can delete it by dragging it to the 
iPhoto Trash, rename it by double-clicking, file it in a folder by dragging it there, 
and so on.

Second, you see the miniature page-layout program shown below, displaying thumb-
nails of the individual pages after iPhoto automatically fills them with photos. (This 
is called All Pages view.) Now the most time-consuming phase begins: designing the 
individual pages. 
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To open a page so you can tweak it, double-click its thumbnail in All Pages view. 
iPhoto displays a larger working version of the page in the main editing area. This 
is called Single Page view. (To get back to All Pages view, click the All Pages arrow 
button near the top of the iPhoto window.)

The key to understanding iPhoto 11’s book-layout mode is realizing that all photos 
are draggable. You can swap two photos by dragging one directly on top of the other; 
move a photo to a different page of the book by dragging it onto a different page in 
the photo browser; remove a photo from a page by clicking its icon and then pressing 
your Delete key (which makes its icon move up into the unplaced-photos area); add 
an unplaced photo to a page by dragging it out of the unplaced-photos browser onto 
a blank spot of the page; fill in an empty gray placeholder frame by dragging a photo 
onto it from the unplaced-photos area; and so on.

Tip: You can also enlarge or crop a picture, right there on the page, by clicking it. A tiny Zoom slider 
appears above the photo, which you can use to magnify the picture or shift it inside its boundary “frame.” 
This trick is helpful when you want to call attention to one part of the photo, or to crop a photo for book-
layout purposes without actually editing the original.
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Photos aren’t the only ones having all the fun. In All Pages view, you can drag and 
manipulate the pages themselves, too. Here’s how:

• Move	pages around within the book by dragging their thumbnails.
• Remove	a	page from the book by clicking its icon and then pressing Delete. 
• Insert	a	new	page into the book by clicking the Add Page button at the bottom 

of the window.

Before blowing a bunch of money ordering copies of your book, you’d be wise to 
proofread and inspect it from every possible angle, either by printing it (File→Print) 
or by saving it as a PDF file (choose File→Print, and then click the “Save as PDF” 
button).

When you think your book is ready for birth, click Buy Book. After several minutes 
of converting your design into an Internet-transmittable file, iPhoto displays a dia-
log box where you can pick a quantity and place your order.

Creating Calendars and Cards

The process for making calendars and cards is nearly identical to the process for 
making books (described above). Select some photos, then click the Create button 
on the iPhoto toolbar and choose Calendar (or Card). iPhoto opens up a screen 
that lets you make the big decisions about your Calendar’s (or Card’s) theme. When 
you’ve settled on your choices, click Create to set out the layout and then Buy Calen-
dar (or Card) at the bottom of the screen. 

Publishing Photos on the Web 
Putting your photos on the Web is the ultimate way to share them with the world. 
If the idea of allowing the vast throngs of the Internet-using public to browse, view, 
download, save, and print your photos sounds appealing, read on. 

It’s amazingly easy to get your photos from iPhoto onto Flickr.com, Facebook.com, 
and MobileMe. In general, here’s what you do (each site has a few quirks, covered 
later on):

1.	 Create	 a	 Flickr,	 Facebook,	 or	 MobileMe	 account	 (if	 you	 don’t	 already	 have	
one).	
Simply open your web browser, go to the website you’re interested in. Look for 
the Sign Up or Create Your Account section, and provide the required info. 
Flickr.com and Facebook.com offer free accounts; MobileMe costs money (keep 
reading for details).

2.	 Back	in	iPhoto,	click	Share→Flickr	(or	Facebook,	or	MobileMe)	to	link	iPhoto	
to	your	web	account.
iPhoto opens a slightly different pop-up menu for each site, but the gist is the 
same: You need to provide your username and password, agree to the site’s 
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terms and conditions, and confirm that you want to link your iPhoto galleries 
with your online account. 

3.	 Select	some	photos	and	then	click	Share→Flickr	(or	Facebook,	or	MobileMe).	
iPhoto sprouts a pop up window in the bottom right. The options in this win-
dow will vary a little bit, depending on how many photos you picked and where 
you’re sending them. For instance, if you share a single photo to Facebook, this 
window will give you the chance to post the shot as your profile pic (below). 
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4.	 Click	one	of	the	sharing	options	in	the	pop-up	window	to	publish	your	shot(s).	
For instance, in the image above, Lesa clicked Profile Picture and Facebook up-
dated her profile accordingly. If iPhoto asks for more info (like what text you’d 
like to appear with a photo on a Facebook wall, or what comment you want to 
add to a photo), type this in now. 

5.	 Finally,	click	Publish	to	put	your	shot(s)	online.

That’s all there is too it. From here on out, it’s a two-way street between your online 
account and iPhoto: If you add (or delete) a photo to album in the source list in 
iPhoto, the shots go up (or down) online. You can see (and access) your joint iPhoto/
online albums in the Source List below the Web tab.

To remove photos from the web, click the name of your online account in the Source 
List (it’ll have a Facebook, Flickr, or MobileMe logo next to it). Then double-click 
the name of the album whose photos you want to remove, select one or more pic-
tures, and click delete. iPhoto takes those photos off the Internet, but it keeps a copy 
on your machine.

To break the link between iPhoto and your online account, click iPhoto→Preferences 
and select the Accounts tab. Then, select your account on the left side of the window 
and click the minus button (it’s in the bottom left of the window). Your albums are 
now unlinked—but your online accounts still have copies of your posted photos. If 
you want to take them down, you’ll need to remove them via the Flickr, Facebook or 
MobileMe websites.

Tip: If you already have a website, it’s easy to create HTML pages of photos that you can post there. First, 
select some photos and. Next choose File→Export, and then click the Web Page tab. Tweak the various 
settings in the dialog box that appears, and then click Export. iPhoto generates a complete set of HTML 
documents and linked, nested folders (containing both thumbnails and full-size images), ready to upload 
to your site. 

Now that you understand the general steps, here are the most important details 
about each site: 

• Flickr	 is a busy photo-sharing website run by Yahoo. Like iPhoto, it holds and 
organizes your pictures—but it uses got some different terminology. What iPhoto 
calls albums, Flickr calls sets. Plus, Flickr has something called a photostream, 
which is like a giant bucket that stores all of your uploaded shots. When you up-
load to Flickr, iPhoto gives you the option of making a Flickr set (step 4 above), 
adding your pictures to an existing Flickr set (if you have any), or posting your 
shots to your photostream. And if you’ve geotagged your photos (see page 88 of 
this appendix), this info gets sent to Flickr along with your shots. That means that, 
when you double-click one of your photo’s thumbnails on Flickr.com, you’ll see a 
Yahoo map showing where you snapped the picture.

• Facebook. One heads-up before you post photos here: The people you desig-
nate using iPhoto’s Faces feature (page 84 of this appendix) are automatically 



108 ilife crash course

iPhoto ’11

tagged when you post photos Facebook. In other words, if you’ve tagged Ralph 
using Faces shot and then put that picture of Ralph online, Facebook blabs to all 
your mutual friends that you’ve just tagged Ralph in one of your pictures.

•	 MobileMe, Apple’s online subscription service, provides everything you need to 
put a collection of  photos online. Unfortunately, this service isn’t free: A mem-
bership will set you back $100 per year (though you can try it free for 60 days: 
http://tinyurl.com/3taaovv). But once you’ve ponied up for MobileMe, you’re in 
for a real treat. Instead of posting to a standard Facebook or Flickr page, iPhoto 
publishes your pictures to a gorgeous, interactive Gallery—a delight for anyone 
who knows its web address (and who also has a high-speed connection). Once 
you click Share→MobileMe, iPhoto guides you through configuring your Gal-
lery before you put it online. The image below shows the various display options 
for MobileMe galleries. 

http://tinyurl.com/3taaovv
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Wallpaper and screensavers
Want to plaster a photo of your dog onto your desktop as a wallpaper background? 
Simply select a photo and then click Share→Set Desktop and admire Fido each time 
you boot up. If you select multiple photos (or an album) in iPhoto, the photos be-
come a self-changing desktop background that shows different shots throughout the 
day.

To create a screensaver instead, Choose @app→System Preferences; then click the 
Desktop & Screen Saver icon. Click the Screen Saver tab near the top of the window, 
and then scroll down to the iPhoto album of your choice. Click it to see, in the Pre-
view area, what it will look like.

Burn Disc
iPhoto CDs are discs (either CDs or DVDs) that you can create directly from within 
iPhoto to archive your entire Photo Library—or any selected portion of it—with just 
a few mouse clicks. This is a great way to back up your photos; transfer them to an-
other copy of iPhoto without losing all your keywords, descriptions, and titles; share 
discs with other iPhoto fans; offload photos to CD or DVD as your photo collection 
grows; or merge separate Photo Libraries (such as the one on your iBook and the one 
on your iMac) into a single master library.

Note: These discs do not play in Windows—they’re exclusively for iPhoto’s use.

To create one, select the albums or photos that you want to include on the disc, and 
then choose Share→Burn. Pop in a blank CD or DVD.

Now take a look at the disc info at the bottom of the iPhoto window to make sure 
your pictures will fit on the disc. If the set of photos you want to burn is larger than 
650 or 700 megabytes (for a CD) or about 4.3 gigabytes (for a single-layer DVD), it’s 
not going to fit. You’ll have to split your backup operation across multiple discs. To 
do that, select whatever number of photo albums or individual pictures that will fit 
on a single disc. After burning the first disc, select the next set of photos, and then 
burn another CD or DVD.

Finally, click the Burn button and, in the dialog box that appears, click Burn. When 
the process is done, your Mac spits out the finished CD, ready to use.

Later, if you want to view the contents of your finished disc in iPhoto, pop it back 
into the drive. The icon for the disc appears in the Source list of the iPhoto window. 
If you click the icon, the photos it contains appear in the photo-viewing area, just as 
if they were stored in your Photo Library.


